Sie sind nicht angemeldet.

Werbung

Boote kaufen

Windstärken

Windstärkentabelle

Hallo Besucher, willkommen im Segeln-Forum! Hier kannst Du Dich registrieren, um unser Forum in seiner vollen Pracht genießen zu können! - Weitere Infos zur Registrierung - Login für Mitglieder -

chrhartz

Offizier

Beiträge: 267

Wohnort: München

Bootstyp: Neptun 20

Heimathafen: Bernau, Chiemsee

  • Nachricht senden

641

Sonntag, 27. August 2017, 19:09

Hi Norbert,

beim Netzteil würde ich das Original nehmen. Das hat nämlich einen größeren Querschnitt und
ist als Zwillingskabel ausgeführt.

Es gibt immer wieder Hinweise auf mindestens 2,5 A, das ist aber Unsinn. Tatsächlich braucht der Raspi
rund 700 mA. Es würde also ein Netzteil mit 1 A völlig ausreichen. Nur sind die Kabel oft recht lang und
zu dünn ausgeführt und dadurch kommt es zu einem Spannungsabfall, den der Raspi dann als Unterspannung
erkennt und der sogar zu Fehlfunktionen führen kann.

Da man den Querschnitt des Kabels beim Kauf nicht beurteilen kann, bleibt oft nur der Griff zum Netzteil mit
größerem Strom, in der Hoffnung, dass der Kabelquerschnitt dort entsprechend größer ist.

Daher kommt dann der Hinweis auf das 2.5 A Netzteil. Aber eben nicht wegen des höheren Stromes, sondern
wegen des dickeren Kabels.

Für die Spielereien zu Hause würde ich das originale Netzteil verwenden. An Bord funktionieren diese 12 -> 5 V
Module mit 3 A aus China recht gut.

Ich hätte noch ein Gehäuse für den Raspi mit 7" Display über. Da ist auch eine 2.1/5.5 mm Buchse eingebaut
und besagter 3 A Wandler. Inzwischen habe ich einen eigenen HAT mit der gesamten Stromversorgung gebaut
und hätte das alte Gehäuse mit Wandler und GPS Modul über.

Das verschenke ich gerne, ich kann damit nichts mehr anfangen. Bei Interesse bitte PN an mich.

Viele Grüße,
Christian
Neptun 20, Segelnummer 950, Honda 5BFU, Liegeplatz Bernau/Chiemsee

noopd

Lichtmaschinenerklärbär

Beiträge: 417

Wohnort: Krefeld

Schiffsname: Last Boy Scout

Bootstyp: Dehler Optima 106

Heimathafen: Workum

Rufzeichen: DG8965

MMSI: 21179450

  • Nachricht senden

642

Sonntag, 10. September 2017, 17:41

AIS GPS USB Empfänger

Hallo Forum,
Ich habe letzte Woche neues Spielzeug dazu bekommen.
AIS-Spotter
Nach der Installation habe ich nun folgendes Problem:
Bei OPEN CPN funktioniert alles
Bei Chart Navigator Light wird, obwohl der COM-Port erkannt wird, weder GPS noch AIS Daten übertragen.
C N L zeigt im Screen an das kein GPS Gerät angeschlossen ist.

Wer weis Rat? :O

Für die AIS Daten bin ich sogar an den Rhein gefahren und konnte so den Test mit OPEN CPN konntroliert durchführen.

Handbreit

Norbert
Prosecco kaltstellen ist irgendwie auch wie kochen. :wacko3:

columbus488

Schief-made

Beiträge: 13 353

Schiffsname: Azurit

Bootstyp: Spirit 28 ( van Heygen )

Heimathafen: Kühlungsborn

Rufzeichen: DD7917

MMSI: 211 625 930

  • Nachricht senden

643

Sonntag, 10. September 2017, 20:00

@noopd: gib bitte mal noch weitere Details zu Betriebssystem etc.
Entspanne dich. Lass das Steuer los. Trudle durch die Welt. Sie ist so schön.
Kurt Tucholsky

chrhartz

Offizier

Beiträge: 267

Wohnort: München

Bootstyp: Neptun 20

Heimathafen: Bernau, Chiemsee

  • Nachricht senden

644

Montag, 11. September 2017, 12:35

Hallo Norbert,

laut Handbuch funktioniert AIS nur mit der professional-Version.

Bei der Light-Version müsste zumindest GPS funktionieren. Welcher COM-Port ist denn zugewiesen?
Manchmal kommen Programme mit zu hoher COM-Nummer nicht klar. Dann würde die manuelle
Zuweisung über die Systemsteuerung helfen. Portnummern unter acht funktionieren bei den meisten
Programmen.

Viele Grüße,
Christian
Neptun 20, Segelnummer 950, Honda 5BFU, Liegeplatz Bernau/Chiemsee

645

Montag, 11. September 2017, 14:10

Hallo Andreas erst einmal herzlichen Dank für avnav!
Ich habe es problemlos auf dem Raspi 3 zum Laufen bekommen.
Beim AIS haperte es etwas ( https://github.com/dgiardini/rtl-ais - trotz Kalibrierung) - mit dem RTL-SDR-Stock von NOOB 0.5ppm TCO dann ohne Probleme. (nachdem ich herausfand, an welchen Port man RTL-AIS leiten muss)
Also habe ich Freitag meine erste Inlands Tour Seen, Flüsse, Kanäle um Berlin, beendet.

Die Routenfunktion war dabei sehr hilfreich und auch das AIS half mir bei unübersichtlichen Kanalkreuzungen.

Allerdings kam in mir ein Wunsch sehr deutlich hervor: Kann man die Anzeigen umparametrieren (km/nm - km/h - kn)?
Gerade bei Geschwindigkeitsbegrenzungen ist das sehr hilfreich.

Herzlichen Dank vorab.

Liebe Grüße
Thomas

646

Montag, 11. September 2017, 22:01

Bisher kann man das nicht ändern.
Wäre sicher ein nettes feature...
Habe es mal aufgeschrieben als einen Wunsch https://github.com/wellenvogel/avnav/issues/34.

noopd

Lichtmaschinenerklärbär

Beiträge: 417

Wohnort: Krefeld

Schiffsname: Last Boy Scout

Bootstyp: Dehler Optima 106

Heimathafen: Workum

Rufzeichen: DG8965

MMSI: 21179450

  • Nachricht senden

647

Dienstag, 12. September 2017, 06:35

Zitat

Welcher COM-Port ist denn zugewiesen?

Com7 ist zugewiesen. Kein GPS bei dem sie spotter.
Bei einer reinen GPS Maus wird com6 zugewiesen. Funktioniert.

Bei Open cpn sind beide Ports vorhanden und abwechselnd schaltbar.

Handbreit

Norbert
Prosecco kaltstellen ist irgendwie auch wie kochen. :wacko3:

Beiträge: 1

Wohnort: Bremen

Heimathafen: Neustadt in Holstein

  • Nachricht senden

648

Samstag, 21. Oktober 2017, 11:27

NV Chart Karten in Opelplotter einfügen ?

Hallo Zusammen,
kann mir jemand helfen NV Chart Karten von der Ostsee in OpenCPN auf dem Raspberry einzufügen ?
Ich habe den Kartensatz Serie 2 von NV Chart gekauft Papier und auch die entsprechende CD sowie einen Produktschlüssel dazu erhalten.
Leider werden die Karten so nicht angezeigt und das Plugin geht anscheinend nur für Windows ?

Mit freundlichen Grüßen
Ulf

649

Samstag, 21. Oktober 2017, 12:34

Leider werden die Karten so nicht angezeigt und das Plugin geht anscheinend nur für Windows ?


Leider geht nicht. Nur für Windows
https://opencpn.org/OpenCPN/plugins/nvcharts.html

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »BlackSea« (21. Oktober 2017, 12:47)


otto_motor

Bootsmann

Beiträge: 129

Wohnort: Kreis Marburg-Biedenkopf

Bootstyp: Bavaria 32

Heimathafen: Lemmer

  • Nachricht senden

650

Montag, 4. Dezember 2017, 00:18

Ich hätte eine banale Frage: Wo ändere ich die SSID?
Gruß Easy.
----------------------------------------------------------------------------------------------------------------------------------
Mein Name ist Guybrush Threepwood und ich will Pirat werden!

651

Montag, 4. Dezember 2017, 07:10

SSID - für avnav?
In /etc/hostapd.conf.* - separat für jedes WLAN.

otto_motor

Bootsmann

Beiträge: 129

Wohnort: Kreis Marburg-Biedenkopf

Bootstyp: Bavaria 32

Heimathafen: Lemmer

  • Nachricht senden

652

Montag, 4. Dezember 2017, 08:49

Vielen Dank für die super-schnelle Antwort. Gestern Abend hat es nicht geklappt, heute morgen schon.
In dem Verzeichnis sind ja ein paar conf Dateien. Ich hatte zwar auch diese auch mit sudo nano editiert, nur hatte ich das Problem, dass nach dem Reboot diese mit den ursprünglichen Werten überschrieben wurde. Es muss wohl spät gewesen sein. Vermutlich ein Bedienfehler.
Gruß Easy.
----------------------------------------------------------------------------------------------------------------------------------
Mein Name ist Guybrush Threepwood und ich will Pirat werden!

otto_motor

Bootsmann

Beiträge: 129

Wohnort: Kreis Marburg-Biedenkopf

Bootstyp: Bavaria 32

Heimathafen: Lemmer

  • Nachricht senden

653

Montag, 25. Dezember 2017, 14:03

Jetzt stehe ich vor der nächsten Entscheidung: Auf meinem neuen Boot ist ein NMEA 2000 Netzwerk. Das heißt, ich brauche einen Konverter. Ist dafür VYacht geeignet? Die Daten kämen ja dann nicht über ein serielles Kabel, sondern über Wlan rein. Kann Avnav damit was anfangen?
Gruß Easy.
----------------------------------------------------------------------------------------------------------------------------------
Mein Name ist Guybrush Threepwood und ich will Pirat werden!

654

Montag, 25. Dezember 2017, 19:36

Ja, avnav kann auch problemlos Daten aus dem WLAN lesen.
Socketreader istvdas Stichwort.
Je nachdem, wie VYacht das bereitstellt - TCP oder UDP sieht die config etwas anders aus.

655

Samstag, 10. Februar 2018, 15:05

Position wird im Menü nicht angezeigt

Hallo liebe Leute,
zunächst mal: vielen Dank für dieses großartige Projekt! Es ist wirklich großartig und genau das, was ich gesucht hab für Logs am See / beim Chartern. Nachdem ich die Seite und die Karten zum Laufen gebracht hab und auch per 'gpsmon' auf meinem Raspi eine aktuelle GPS-Position angezeigt bekomme, siehts im AVNAV leider düster aus. Auch im Status steht NMEA receiving per GPSDReader vom device /dev/ttyAMA0 über einen seriell angeschlossenen Navilock NL-652ETTL.

Hier mal ein Auszug aus der avnav_server.xml

Quellcode

1
2
<AVNGpsdFeeder useGpsd="false" listenerPort="4020" port="2947" gpsdcommand="/usr/sbin/gpsd -b -n -N -G"/>
<AVNGpsd device="/dev/ttyAMA0" port="2947" timeout="400" baud="38400"/>


Und aus dem avnav.log gibts folgende Hinweise:

2018-02-08 23:03:00,375-315-MainThread-INFO-#### avnserver pid=315,version=20170410,parameters=/usr/lib/avnav/server/avnav_server.py -c /home/pi/avnav/data/charts -u viewer=/usr/lib/avnav/viewer,libraries=/usr/lib/avnav/viewer/libraries$
2018-02-08 23:03:00,394-315-[666]GPSDReader-dev:/dev/ttyAMA0-port:2947-INFO-started for /dev/ttyAMA0 with command /usr/sbin/gpsd -b -n -N -S 2947 /dev/ttyAMA0, timeout 400.000000
2018-02-08 23:03:00,402-315-[667][665]AVNGpsdFeeder[standalone feed]-INFO-standalone feeder started
2018-02-08 23:03:00,416-315-[668]UdpReader-127.0.0.1:34667-INFO-successfully listening at 127.0.0.1:34667
2018-02-08 23:03:00,427-315-[669]HTTPServer-INFO-HTTP server raspberrypi, 8080 started at thread [669]HTTPServer
2018-02-08 23:03:00,440-315-[666]GPSDReader-dev:/dev/ttyAMA0-port:2947-INFO-device /dev/ttyAMA0 became visible, starting gpsd
2018-02-08 23:03:00,500-315-[670]AVNTrackWriter-INFO-started with dir=/home/pi/avnav/data/tracks,interval=10, distance=50
2018-02-08 23:03:00,438-315-[668]UdpReader-127.0.0.1:34667-INFO-UDP: 127.0.0.1:34667 established, start reading
2018-02-08 23:03:00,536-315-[675]AVNChartHandler-ERROR-unable to find AVNHTTPServer
2018-02-08 23:03:00,546-315-[670]AVNTrackWriter-INFO-new trackfile /home/pi/avnav/data/tracks/2018-02-08.avt
2018-02-08 23:03:00,526-315-Thread-14-INFO-trying to add gemf file /home/pi/avnav/data/charts/Unnamed atlas.gemf
2018-02-08 23:03:00,557-315-Thread-15-INFO-TrackWriter:converter thread 674 started
2018-02-08 23:03:00,563-315-MainThread-INFO-starting importer with directory /home/pi/avnav/data/import, tools dir /us ...
2018-02-08 23:03:00,570-315-[678]AVNNmeaLogger-INFO-starting logger with maxfiles = 100, filter=$RMC,$DBT,$DBP, interval=5s
2018-02-08 23:03:00,636-315-[678]AVNNmeaLogger-INFO-new nmea logfile /home/pi/avnav/data/tracks/2018-02-08.nmea
2018-02-08 23:03:00,571-315-[677]AVNRouter-INFO-read 0 routes
2018-02-08 23:03:00,655-315-Thread-14-INFO-created GEMF overview for /home/pi/avnav/data/charts/Unnamed atlas.gemf
2018-02-08 23:03:00,685-315-Thread-14-INFO-successfully added gemf file Unnamed atlas.gemf GEMF /home/pi/avnav/d...
2018-02-08 23:03:00,680-315-MainThread-INFO-All Handlers started
2018-02-08 23:03:00,718-315-[677]AVNRouter-INFO-router main loop started
2018-02-08 23:03:02,489-315-[672]AVNSocketWriter-34567-INFO-listening at port address ('0.0.0.0', 34567)


Interessanterweise zeigt auch im AVNAV Startbildschrim bspw. NMEA: Sat 13 visible / 6 used aber unter Pos. gähnende Leere.
Leider konnte ich auch die Zeit über ntpd nicht aktualisieren. Wisst ihr da Rat?

Vielen Dank im Voraus für eure Mühen und ganz liebe Grüße aus Tirol,
Alex

656

Sonntag, 11. Februar 2018, 08:55

Leider konnte ich auch die Zeit über ntpd nicht aktualisieren. Wisst ihr da Rat?


Die Zeit wird automagisch von ntpd ( aus gps ) gesetzt. Da brauchst du nicht darum zu kümmern

Seriellen GPS-Receiver hast du zu kompliziert angebunden. Du kannst deine Einträge wieder zurücknehmen.
1. Sorge dafür dass der Serial richtig konfiguriert wird
https://learn.adafruit.com/adafruit-ulti…-instead-of-usb

2. Prüfe ob du die NMEA Daten empfängst auf dem Anschluß

3. In avnav.xml folgenden Eintrag

Quellcode

1
<AVNSerialReader useFeeder="true" name="GPSReader" port="/dev/ttyAMA0" baud="38400" numerrors="20"/>


Viel Glück!!

657

Sonntag, 11. Februar 2018, 10:05

Insgesamt solltest Du nicht gleichzeitig den gpsd vom System starten lassen und dazu noch versuchen, ihn über avnav zu starten.
Um Konflikte zu vermeiden bitte den gpsd nicht vom Linux starten lassen (ist in meinen Images auch abgeschaltet). Sonst musst Du zumindest dafür sorgen, das er nicht auch versucht, das gleiche device zu nutzen.

Zur Zeit:
Bei Dir mit "useGpsd=false" setzt avnav die Systemzeit aus den gps Daten. Das wird periodisch wiederholt, wenn die Zeitdifferenz zu groß wird (5s als default). Das ist zwar nicht so perfekt wie eine direkte Einbindung in ntp, reicht aber für die meisten Fälle gut aus.
Falls useGpsd=true ist, wird die Zeit per ntpd korrekt gehalten - dann hat man aber wieder das problem, das hier potentiell 2 gpsd Instanzen sich gegenseitig stören.

658

Montag, 12. Februar 2018, 20:48

Funktioniert :-)

Hallo BlackSea, hallo Wellenvogel,

vielen Dank für eure Tipps. Es war (3.):
3. In avnav.xml folgenden Eintrag

Quellcode

1
<AVNSerialReader useFeeder="true" name="GPSReader" port="/dev/ttyAMA0" baud="38400" numerrors="20"/>

Nachdem der Feeder funktioniert hat, hats auch mit der Zeit funktioniert. Sieht so aus, als ob ich da den Reader falsch konfiguriert hatte. Ich habs zwar auch schon mal mit diesem Reader versucht, aber irgendwo hats wohl gezwickt.

Vielen Dank für eure rasche Hilfe!
Schöne Grüße und noch einen schönen Abend,
Alex

659

Dienstag, 6. März 2018, 19:54

Neues Image

So - langsam wird es Frühling...
Falls also noch jemand in die Raspi-Basteltätigkeit einsteigen möchte - es gibt ein neues Image für avnav, das auf dem aktuellsten debian basiert.
http://www.wellenvogel.net/software/avna…ads/release.php
Natürlich kann man auch nach wie vor (wie dort beschrieben) nur die Pakete updaten.
Viel Spass beim Basteln - und Frage/Hinweise/Fehler wie immer gerne hier.

660

Mittwoch, 7. März 2018, 08:53

Danke Andreas!!!

Immer wieder schön, AvNav auf Vordermann zu bringen. :phil_04:

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 1 514   Hits gestern: 2 479   Hits Tagesrekord: 5 297   Hits gesamt: 3 807 985   Hits pro Tag: 2 340 
 Seitenaufrufe:   Klicks heute: 11 400   Klicks gestern: 17 137   Klicks Tagesrekord: 154 353   Klicks gesamt: 31 246 768   Klicks pro Tag: 19 201,1 

Kontrollzentrum

Helvetia