Sie sind nicht angemeldet.

Werbung

Boote kaufen

Windstärken

Windstärkentabelle

Hallo Besucher, willkommen im Segeln-Forum! Hier kannst Du Dich registrieren, um unser Forum in seiner vollen Pracht genießen zu können! - Weitere Infos zur Registrierung - Login für Mitglieder -

Beiträge: 1

Wohnort: Duisburg

Schiffsname: Robin

Bootstyp: Biga 23

  • Nachricht senden

801

Freitag, 15. März 2019, 15:30

Für Navionics: UDP Writer auf Port 2000 ?

Moin Andreas,

ich habe mich etwas mit der Kopplung nach Navionics beschäftigt, da die Vektorkarten sehr handlich und günstig sind (31 EUR für ganz West-Europa).
Leider weigert sich die Navionics-APP beharrlich, AIS Targets anzuzeigen, so dass nur die GPS Daten vom AVNAV übernommen werden.
Aber dafür gibt es ja iAIS, das die NMEA Daten vom AVNAV TCP Port (original 34567) gerne verarbeitet und auf Navionics Karten einblendet.

Ich möchte AVNAV als Minimallösung und Navionics als weitere Info-Quelle mit aktuellen Karten nutzen.
Könntest Du vielleicht in einem Deiner nächsten Releases einen UDP Writer auf Port 2000 vorsehen,
der auf eine einzelne IP oder auf die Broadcast IP vom wlan-ap die NMEA Daten verbreitet ?
Auf diesem Port "hört" nämlich Navionics und nimmt die GPS Daten klaglos an.

Bis dahin begnüge ich mich mit dem Workaround netcat:
"nc 127.0.0.1 34567 | nc -u <IP des Navionics tablets oder Broadcast IP> 2000".

Viele Grüße
und: Handbreit !

Roland.

Meine Hardware: Raspi Zero/W mit USB Hat, NooElec Nano 3 SDR, QGP USB GPS Empfänger und USB-WLAN
Software: AVNAV-Touch Version 20180313 von Holger Pandel

Noseman

Moses

Beiträge: 5

Bootstyp: Albin Vega / ETAP 22i

  • Nachricht senden

802

Samstag, 16. März 2019, 00:18

In der avnav_server.xml einen weiteren Socketwriter eintragen, oder kann der nur TCP??
Ansonsten kplex einbinden, hier die config:
[udp]
name=navionics
direction=outoptional=yes
address=192.168.1.255
port=2000

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Noseman« (16. März 2019, 00:32)


803

Samstag, 16. März 2019, 06:34

Einen udp sender gibt es bisher nicht.
Könnte ich aber mal einbauen...

804

Montag, 18. März 2019, 21:52

Hallo Zusammen,
es handelt sich bestimmt um einen dumme Frage...
Wie kann ich die alten Tracks auf der Karte im Avnav ansehen?
Ich komme nur bis zum Downloadbereich - und dann...
Gruß
Guido

805

Dienstag, 19. März 2019, 11:28

AvNav zeigt nur die letzten 24 Stunden track. Für alles anderes: GPX Datei runterladen und in anderem GPX fähigem Viewer anschauen

806

Montag, 25. März 2019, 10:05

Ich möchte AVNAV als Minimallösung und Navionics als weitere Info-Quelle mit aktuellen Karten nutzen.
Könntest Du vielleicht in einem Deiner nächsten Releases einen UDP Writer auf Port 2000 vorsehen,
der auf eine einzelne IP oder auf die Broadcast IP vom wlan-ap die NMEA Daten verbreitet ?
Auf diesem Port "hört" nämlich Navionics und nimmt die GPS Daten klaglos an.


Hallo @Robinsailor,

ich habe die letzte Woche das implementiert. Du kannst das ausprobieren
Kopiere https://raw.githubusercontent.com/free-x…er/udpwriter.py nach /usr/lib/avnav/server/handler
Und aktiviere in avnav_server.xml mit Eintrag

Quellcode

1
<AVNUdpWriter host="192.168.30.255" port="2000" filter=""/>


Evtl 192.168.30.255 mit richtiger Broadcast Addresse ersetzen ( weiss nicht was bei Zero vergeben wird)



Gruß
BlackSea

ocean sailor

Proviantmeister

Beiträge: 299

Schiffsname: LULU

Bootstyp: Moody 34

  • Nachricht senden

807

Mittwoch, 3. April 2019, 23:07

iPad

Soweit ich verstehe willst du die AIS Tagets auf einem iPad mittels iNav auf Navionics als Overlay darstellen. INav verwendet eigene Hardware um die AIS Daten darzustellen(Info vom Messestand Boot). Seit mir mehrere Images gecracht sind werde ich mich mit dem Raspberry Zeug nicht mehr auseinandersetzen. Wenn ich segel benötige ich ein System das sicher ist. Zum anderen sollten wir Alle einen Transponder an Bord haben. Die kommerzielle Schifffahrt halt Ausschau nach AIS Signalen. AIS wird auch von den Landstationen protokolliert und im Falle eines Unfalles werden die Daten verwertet. Wenn man den Markt beobachtet, wird man feststellen, das es mittlerweile AIS Transponder inklusive Plotter mit Seekarten (K-Chart 3.0) bereits für 430 Euro in den Niederlanden erhältlich ist (ONWA KP-39A). Ich besitze dieses Gerät, möchte aber lieber mit Navionics navigieren. Habe im letzten Jahr festgestellt, das die Navionics Karten mindestens 4 Mal in Polen upgedated wurden.
Ich fahre im Moment zweigleisig, Navionics auf Android Tablet und AIS auf dem ONWA KP-39A. Dieses ist auch keine zufriedenstellende Lösung. Die Raspberry Lösung ist unzuverlässig. K-Chart ist auch keine Lösung, da die Karten nicht upgedated werden. Habe mir auch Cmap im Internet angeschaut und festgestellt, dass die Navionics aktueller sind. Nach dem letzen Crash werde ich mit dem Rapsberry Mist nicht weiter machen. Komme aus der IT Sun Solaris, MCSE, SQL,Exchange, MS Server 2008...Die AiS Signale und Position schicke ich bereits über WLAN.....zur weiter Verarbeitung UDP Port 2000....Würde das gerne mit Navionics integrieren. Zur Not kaufe ich mir auch ein iPad....

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »ocean sailor« (3. April 2019, 23:32)


808

Donnerstag, 4. April 2019, 11:57

Seit mir mehrere Images gecracht sind werde ich mich mit dem Raspberry Zeug nicht mehr auseinandersetzen.


Was hast du da benutzt? War das wirklich AvNav? Oder irgendwas mit viel Grafik(OpenCPN)?

Zitat


Die kommerzielle Schifffahrt

Die haben sowieso andere Anforderungen. Angefangen mit "alles Doppelt mitzuführen". Du konntest auch wenigstens ein Backup von SD Karte anfertigen ;)

Zitat


Komme aus der IT Sun Solaris, MCSE, SQL,Exchange, MS Server 2008


Kenntnisse aus Solaris ist schon mal gut fürs Anfang, alles anderes ist irrelevant für Raspberry :D

Moeritsen

Offizier

Beiträge: 177

Schiffsname: Hella

Bootstyp: Bandholm BA 30

Heimathafen: Kiel

  • Nachricht senden

809

Samstag, 6. April 2019, 11:11

Moin allerseits,

Eine Frage an die Elektroniker unter euch:
Aufgrund des Projektes von Norbert Walter (Windmessanlage) habe ich mir auch eine Raspberry-Umgebung für unser Boot aufgebaut.
Es läuft Openplotter zunächst auf einer SD-Karte. Daran angeschlossen eine USB-Maus und 3 RS485-USB-Wandler an einem passiven USB-Hub. Dort läuft AIS auf und GPS raus zum Funkgerät, ferner ein NMEA-Echolotgeber (P79S). Damit ich bequem die USB-Schnittstellen und den Raspi selbst mit genügend Strom versorgen kann, sitzt auf dem Raspi eine StromPi2-Platine von Joytech.
Soweit lief das eine Saison wunderbar und ohne Probleme.

Nun dazu gekommen: Ein Faytech-Monitor fürs Schott, per HDMI angeschlossen. Monitor und Raspberry sind einzeln mit jeweils 2A-Sicherungen abgesichert, liegen im gleichen Stromkreis.
Bei der ersten Fahrt fällt die ganze Geschichte plötzlich aus. Fehlerbild: die SD-Karte scheint defekt, der Raspi bootet nicht mehr. Der Monitor bleibt schwarz, auch nachdem ich ihn an ein Tablet angeschlossen habe. Eine nähere Untersuchung zeigt: eine Leiterbahn auf der StromPi2-Platine hat sich abgelöst und ist gerissen, offenbar ein thermisches Problem. Die Sicherungen bleiben intakt.

Soweit scheint alles klar, neue StromPi2-Platine gekauft und gleich auch eine SSD, um den Betrieb schneller und sicherer zu machen, kosten ja nichts mehr, die Dinger. Nun kommen die Merkwürdigkeiten: Von der SSD bootet der Raspi nur unregelmäßig, wenn die neue StromPi2-Platine aufgesteckt ist, wenn die beschriebene USB-Verbindung von Rasp zu StromPi2 aufgesteckt ist, bootet er überhaupt nicht.
Fehlt die StromPi2-Platine, bootet und läuft der Raspi klaglos.

An Bord dann die größere Merkwürdigkeit: Mit aufgesteckter StromPi2-Platine bleibt der Monitor schwarz, bootet zwar (ohne USB-Verbindung) und ist erreichbar über VNC. Aber als ich die StromPi2-Platine weggelassen habe, läuft plötzlich der Monitor wieder. Eine Strommessung mit diesen kleinen USB-Messgerätchen zeigte, dass alle Verbraucher zusammen auf max. 500mA kamen, also die Begründung nicht darin liegen kann, dass der Stromverbrauch im System zu hoch ist. Mein Echolotgeber ist seitdem tot. Alles andere läuft ohne die StromPi2 wunderbar.

Gibt es außerhalb von Magie und Zufall Erklärungsansätze für diese merkwürdigen Phänomene?

Ich habe ein wenig elektronisches Grundwissen und kann auch mit einem Lötkolben umgehen, aber das ist mir unerklärlich und vor allem zu hoch. Euch vielleicht nicht. Bin gespannt auf eure Analysen.

So Long
Michael

810

Sonntag, 7. April 2019, 14:24

Ubuntu Mate auf Raspi

Ich habe Ubuntu Mate auf dem Raspi seit zwei Jahren erfolgreich im Einsatz, v.a. um OpenCPN zu nutzten.
Nun habe ich die neueste Version Open CPN 5.0. erfolgreich getestet.

Dabei habe ich ( dummerwesie ??) versucht das OS zu aktualisieren. Hat nicht geklappt.
Und seit dem kann ich nur noch im "emergency mode" booten.
Meldung:
"Welcome to emergency mode ...., type "this and that" ... or type ctrl D to continue"

ctrl D funktioniert zwar, ist aber irgendwie schlecht.
Terminal sagt mir: Ubuntu 16.04.6 LTS würde laufen.

Fehlermeldung beim booten:
"Failed to start kernel modules"

Hat jemand von euch ne Idee zur Lösung?
Ich will kein neues OS auf die SD Karte schreiben, wegen der frisch installierten Karten von oesenc.

811

Sonntag, 7. April 2019, 18:58

Zu ubuntu und OpenCPN könntest Du vielleicht mehr Hilfe in einem der entsprechenden Threads finden. Oder Du machst einen neuen auf...

columbus488

Schief-made

Beiträge: 13 838

Schiffsname: Azurit

Bootstyp: Spirit 28 ( van Heygen )

Heimathafen: Kühlungsborn

Rufzeichen: DD7917

MMSI: 211 625 930

  • Nachricht senden

812

Dienstag, 9. April 2019, 08:04

@Heiko: schau mal in die Ubuntu Wiki und die angeschlossenen Foren, da findest du idR immer Hilfe
https://wiki.ubuntuusers.de/MATE/
das Leben beginnt, wenn der Mast steht und die Segel angeschlagen sind....

Bandon

Smutje

Beiträge: 25

Wohnort: Berlin

Bootstyp: Contest 29

Heimathafen: Berlin

  • Nachricht senden

813

Dienstag, 9. April 2019, 11:00

NMEA Daten über USB

Hallo zusammen,
eine Frage an die Elektroniker unter euch.
Ich benutze ein RS232 Kabel mit einem SUB-D Adapter ( siehe Bilder ) um die AIS und GPS Daten von der Funke in den AVNav zu senden.
Funktioniert einwandfrei :D
Jetzt ist noch ein PiPi ST2000 dazu gestossen den ich mit den Wegepunkten vom AVNav füttern möchte.
nun die Frage, kann ich die ST2000 NMEA Datenleitung direkt mit auf den SUB-D Adapter klemmen ? oder brauche ich eine komplett neue Leitung samt USB Stecker und socket-reader/writer usw..
Bilder anbei .

Gruß Sven
»Bandon« hat folgende Dateien angehängt:
  • RS232.jpg (2,34 kB - 178 mal heruntergeladen - zuletzt: Gestern, 23:01)
  • SUB-D-Adapter.jpg (2,19 kB - 177 mal heruntergeladen - zuletzt: Gestern, 23:01)
  • ST2000.jpg (27,86 kB - 11 mal heruntergeladen - zuletzt: 23. April 2019, 16:09)

814

Dienstag, 9. April 2019, 18:22

@columbus488: danke für den Tipp. Ich kenne und schätze dieses Wiki sehr, dachte aber das ich für dies spezielle Frage für den Raspi bei euch schneller weiter komme.
Danke!

815

Montag, 15. April 2019, 21:57

Neues Image

Nach langer Zeit gibt es mal wieder ein neues Image: http://www.wellenvogel.net/software/avna…ads/release.php.
Das sollte jetzt auch auf dem Pi3b+ laufen.
Es dort jetzt eine zeroconf/bonjour Konfiguration, so dass ein Pi damit im lokalen Netz mittels der entsprechenden Apps leichter auffindbar sein sollte.
Ausserdem (Dank an BlackSea) jetzt auch ein Senden per Udp.
Daneben die bisher aufgelaufenen Korrekturen.
Ich habe selbst keinen 3B+ - wäre also sehr an feedback interessiert, ob es dort läuft.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wellenvogel« (15. April 2019, 22:22)


Der Beitrag »Raspberry B3+« von »Bandon« (Sonntag, 21. April 2019, 18:50) wurde aus folgendem Grund vom Autor selbst gelöscht: fehler.. (Sonntag, 21. April 2019, 19:23).

817

Sonntag, 21. April 2019, 18:51

Danke für das feedback...

Bandon

Smutje

Beiträge: 25

Wohnort: Berlin

Bootstyp: Contest 29

Heimathafen: Berlin

  • Nachricht senden

818

Sonntag, 21. April 2019, 19:26

sorry, hab mich vertan und den falschen Pi gegiffen.. probiere es jetzt mit dem B+ .. so wie es aussieht bootet er aber nicht mit dem Image. ( Monitor bleibt schwarz )
werde das img nochmals neu auf die KArte schreiben und berichten.

Gruß Sven
sorry, was mein Fehler... zu schnell geschossen

Bandon

Smutje

Beiträge: 25

Wohnort: Berlin

Bootstyp: Contest 29

Heimathafen: Berlin

  • Nachricht senden

819

Sonntag, 21. April 2019, 20:16

so, noch einmal alles neu auf die SD Karte geschrieben (Image 20180305.img), mit sudo dpkg -i avnav_20180415.dep und den Rest installiert.
( der B+ braucht mehr Strom :-( deshalb bleib der Bildschirm schwarz .HDMI Adapter mit externen Stromnetzteil versorgt.)
die Karte vom B in den B+ gesteckt, leider sehe ich ausser den Bunten Startbildschirm vom Raspi nichts weiter. ergo.. er bootet nicht.
die selbe Karte startet im alten B einwandfrei. ( Orginal Raspberian auf einer anderen Karte startet. PI ist also in Ordnung).
vielleicht hast du ja noch eine Idee woran es liegen könnte.

Gruß Sven

Der Beitrag von »Bandon« (Sonntag, 21. April 2019, 21:58) wurde vom Autor selbst gelöscht (Montag, 22. April 2019, 08:00).

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 51   Hits gestern: 2 589   Hits Tagesrekord: 5 297   Hits gesamt: 4 460 880   Hits pro Tag: 2 340,81 
 Seitenaufrufe:   Klicks heute: 319   Klicks gestern: 18 209   Klicks Tagesrekord: 154 353   Klicks gesamt: 35 723 489   Klicks pro Tag: 18 745,61 

Kontrollzentrum