Sie sind nicht angemeldet.

Werbung

Boote kaufen

Windstärken

Windstärkentabelle

Hallo Besucher, willkommen im Segeln-Forum! Hier kannst Du Dich registrieren, um unser Forum in seiner vollen Pracht genießen zu können! - Weitere Infos zur Registrierung - Login für Mitglieder -

Beiträge: 3

Schiffsname: Meduse

Bootstyp: CundC 25

Heimathafen: Lübeck

Rufzeichen: DJ4743

MMSI: 211530350

  • Nachricht senden

81

Montag, 28. Juli 2014, 11:25

Zitat

Ist es bei laufenden "NMEA Server" noch möglich ein XMBC laufen zu lassen, oder ist der Raspberry mit dem multiplexen ausgelastet?

Bei mir braucht er so 10-20% CPU. Hängt ganz stark von den Datensätzen o. Mmmab...




Zitat

Schön gemacht die Anbindung. :good2:
Das gespiele mit dem Rasberry Pi gefällt mir. Schick gemacht und ordentlich erklärt. :good2: :klatschen:
Wäre nur schön, wenn es auf der Webseite besser lesbar ist. ;)




Zitat

Schön gemacht die Anbindung. :good2:
Das gespiele mit dem Rasberry Pi gefällt mir. Schick gemacht und ordentlich erklärt. :good2: :klatschen:
Wäre nur schön, wenn es auf der Webseite besser lesbar ist. ;)




Zitat

Schön gemacht die Anbindung. :good2:
Das gespiele mit dem Rasberry Pi gefällt mir. Schick gemacht und ordentlich erklärt. :good2: :klatschen:
Wäre nur schön, wenn es auf der Webseite besser lesbar ist. ;)

82

Montag, 28. Juli 2014, 21:35

Hallo Lars,
Ist ohne nähere Info schwierig.
Was sagt denn die Status-Seite?
Strom könnte ein Thema sein aber dann würde er eher abstürzen.
Auch das auto-bauding wird Probleme machen, wenn nur selten Daten kommen.
Man kann dann in der avnav_server.xml ggf. eine feste Baudrate einstellen.
Melde mich nochmal mit ein paar Vorschlägen.

83

Montag, 28. Juli 2014, 21:49

@lars:
Du könntest mal das debugging einschalten. Dazu an die URL anhängen: /viewer/avnav_navi.php?request=debuglevel&level=debug - also z.B. http://avnav/viewer/avnav_navi.php?reque…vel&level=debug.
Dann eine Weile laufen lassen und anschließend wieder zurückstellen auf info: http://avnav/viewer/avnav_navi.php?request=debuglevel&level=info.
Dann könntest Du mal den Inhalt von /data/avnav/log/avnav.log posten/mir schicken.
Falls Du es selbst mal mit fester baudrate probieren willst:
Wenn Du in die avnav_server.xml Datei (unter /home/pi/avnav/data) schaust, siehst Du dort auch einen Beispieleintrag für ein USB Device (<UsbDevice usbid="1-1.2.1:1.0" baud="38400" minbaud="4800"/>
).
Du müßtest für Deinen Wandler die USB-ID bestimmen (status-Seite und mal abstecken/wieder anstecken) und einen Eintrag ohne minbaud und mir der richtigen Baudrate anlegen. Dann mußt Du den Wandler allerdings immer an den gleichen USB-Port stecken.
Nach Änderung der Datei den server restarten (sudo service avnav restart).


Gruß Andreas (aus Kaseberga...)




84

Mittwoch, 30. Juli 2014, 21:04

Hallo Andreas,

angehängt ist der Screenshot. Hast Du ein paar Stichworte, wie man eine Route erstellt?

Das mit dem Browser probiere ich mal.

Viele Grüße
Thomas
»ratlos4711« hat folgende Datei angehängt:
  • x.jpg (165,93 kB - 41 mal heruntergeladen - zuletzt: 23. Januar 2019, 22:38)

85

Donnerstag, 31. Juli 2014, 18:57

Hallo Thomas, das scheint noch die ältere Version ohne Routing zu sein.
Du mußt die neue explizit runterladen.
Habe sie noch nicht als die aktuelle eingestellt. Also ein setup.sh update reicht nicht, Du mußt die Url dazu angeben.
Dann solltest Du den routing butoon haben.
Schau mal auf die Version auf der Einstiegsseite.
Gruß Andreas

jensstark

Salzbuckel

Beiträge: 8 258

Wohnort: Halstenbek

Schiffsname: Moi

Bootstyp: Dehler Optima 98GS

Heimathafen: Nestleweg 8, Kappeln

Rufzeichen: DB8094 / (DB9MOI)

  • Nachricht senden

86

Mittwoch, 6. August 2014, 13:06

Ich denke grad' über eine Abwandlung des Ganzen nach.

Ziel ist es, AIS auf dem Plotter auszugeben. Fertiglösungen sind aufgrund der Randbedingungen teuer und zum Spielen kann man ja wunderbar mit dem arbeiten, was man im Haus hat. In meinem Fall ein Funcube Dongle Pro+-SDR und ein Raspberry PI.

Unsere augenblickliche Konfiguration ist ziemlich wirr historisch gewachsen:

Logge, Lot, GPS und Wind gehen über Nexus Server Classic und NMEA0183 mit 4800 auf einen Actisense NGT-1 und von da aus weiter über NMEA2000 auf einen Lowrance HDS-7M Gen2 Touch, der sie dann wieder über NMEA0183 an einen Raymarine ST4000+ Autopiloten weiterreicht. :)

Jetzt könnte man folgendes machen:

Zwischen den Nexus-Server und den NGT-1 einen Raspberry PI mit 2x RS232 (1x Pegelwandler, 1x via USB) anklemmen. Auf der NGT-1-Seite die Geschwindigkeit auf 38400 hochsetzen. Eingehende Pakete vom Server über den Raspberry auf den NGT-1 routen.

Das sollte sich irgendwie machen lassen. :)

Für AIS einen vorhandenen Funcube Dongle Pro+ an den Raspberry und den vorhandenen Antennensplitter hängen.
Der spielt Soundkarte mit 192KHz, braucht erheblich weniger CPU zur Auswertung als die RTLSDRs.
Auf eine der AIS-Frequenzen einstellen und beispielsweise mit gnuais oder aisdecoder decodieren und die NMEA-Meldungen in Richtung NGT-1 schicken.

Gibt es zu dem Punkt AIS mit Raspberry PI und FCD+ (nicht RTLSDR, der dürfte zu viel CPU-Last produzieren) schon Erfahrungen im Forum?
(Weiterentwicklung wäre auch denkbar - kleinen Thermodrucker anschließen und das Ganze als NAVTEX-Empfänger mit dem look and feel der 80er mißbrauchen. :) )

Beiträge: 79

Schiffsname: perfect match

Bootstyp: Grand Soleil 40

Heimathafen: Laboe

  • Nachricht senden

87

Donnerstag, 7. August 2014, 20:29

Hallo Andreas,

Hab ein paar Tage hier nicht reingeschaut, sind auch so Tour gerade in Marstrand.

Ich werde es mal mit festen Bautrate testen und mir den USB Port markieren... Ich werde berichten... Danke das Du dir so schnell Gedanken gemacht hast. Dein Image läuft super zuverlässig!
Beste Grüße

Lars

88

Sonntag, 10. August 2014, 20:50

So - zurück vom Urlaubstörn - und ein paar minimale Korrekturen + Verbesserungen - download wie gewohnt auf http://www.wellenvogel.net/software/avna…loads/index.php.
Oder auch einfach setup.sh update...

Gruß Andreas

txg

Salzbuckel

Beiträge: 2 339

Wohnort: Florida - Bermuda - Azoren- Europa

Schiffsname: Mila

Bootstyp: Dufour 35

Heimathafen: Berlin

  • Nachricht senden

89

Dienstag, 19. August 2014, 12:22

Nachdem es hier ja in letzter Zeit diverse Threads zu UMTS-Routern gab:

Wäre es nicht ein leichtes, dem Raspberry noch einen UMTS-Stick zu verpassen und darüber gleich noch den Internetzugang zu verteilen?

90

Mittwoch, 20. August 2014, 07:42

Das geht bestimmt. Haben auch schon verschiedene Leute gemacht. Für mich ist das im Moment nicht ein so spannendes Thema, deshlb habe ich so einen Stick bisher nicht. Vielleicht kann ja jemand mal eine Beschreibung oder einen Link posten.

91

Dienstag, 26. August 2014, 20:41

Neue Version - GPS-Anzeige in groß

Für alle, die (wie ich) aus gewisser Entfernung immer sehr genau hinschauen müssen, gibt es eine Seite, die die GPS-Daten in groß anzeigt:
index.php?page=Attachment&attachmentID=176281
Download wie immer unter http://www.wellenvogel.de/software/avnav/downloads/index.php.
Ist auch als aktuelle Version eingestellt, also einfach setup.sh update. Bitte beim update von sehr viel älteren Versionen die Hinweise auf der download Seite beachten.

txg

Salzbuckel

Beiträge: 2 339

Wohnort: Florida - Bermuda - Azoren- Europa

Schiffsname: Mila

Bootstyp: Dufour 35

Heimathafen: Berlin

  • Nachricht senden

92

Dienstag, 26. August 2014, 20:44

Die GPS-Anzeige sieht gut aus!

Mal noch eine Anregung die mir bei Navionics fehlt:
Wie wäre es mit einem Nachtmodus? Also roter Text bzw. rote Kartendarstellung auf schwarzem Hintergrund. Das dürfte doch relativ einfach umzusetzen sein und wäre ein tolles Feature.

saltygoose

Super Moderator

Beiträge: 4 352

Schiffsname: Salty Goose

Bootstyp: Ganter 26

Heimathafen: Goose bay

Rufzeichen: Gack

  • Nachricht senden

93

Dienstag, 26. August 2014, 21:19

Kann die Software eigentlich auch den Strom berechnen? Müsste doch theoretisch gehen mit Signal aus der Logge und den GPS-Daten. Fehlt eigentlich nur noch der Kompasskurs in der Berechnung.
:music: Es grüßt Frank :music:

praxis-spranger.de

94

Mittwoch, 27. August 2014, 18:04

Die GPS-Anzeige sieht gut aus!

Mal noch eine Anregung die mir bei Navionics fehlt:
Wie wäre es mit einem Nachtmodus? Also roter Text bzw. rote Kartendarstellung auf schwarzem Hintergrund. Das dürfte doch relativ einfach umzusetzen sein und wäre ein tolles Feature.

Das wird nicht ganz so einfach. An den Karten kann man nicht viel machen, die sind Bilder. Man könnte sie vielleicht dimmen und den Rest dann anders darstellen. Ich überlege mal....

95

Mittwoch, 27. August 2014, 18:10

Kann die Software eigentlich auch den Strom berechnen? Müsste doch theoretisch gehen mit Signal aus der Logge und den GPS-Daten. Fehlt eigentlich nur noch der Kompasskurs in der Berechnung.

Ja, das sollte relativ einfach sein. Gibt für mich nur 2 Probleme:
1. Wohin mit der Anzeige?
2. Ich habe keine Logge mit NMEA. Wenn jemand ein paar NMEA Testdaten mit GPS und Logge für mich hätte, könnte man da sicher was machen.
Für mich ganz oben stehen im Moment:
Routen Ex- und Import
Track Export
Dokumentation

Gruß Andreas

96

Donnerstag, 28. August 2014, 00:21

So - eine erste Demo für einen Nacht-Modus gibt es schon mal:
http://www.wellenvogel.net/software/avnav/demo.php.
Nur das Abdunkeln der Karte geht nicht mit den online-Karten (das geht aber wenn sie vom Raspi kommen).
Muss noch ein wenig testen, dann kann ich auch eine neue Version bauen.

Gruß Andreas

97

Sonntag, 31. August 2014, 20:14

Nachtmodus

So - hier ist nun die Version mit dem Nacht-Modus:
http://www.wellenvogel.net/software/avna…loads/index.php.
Sieht dann z.B. so aus:
index.php?page=Attachment&attachmentID=176484

Gruß Andreas

98

Montag, 1. September 2014, 22:51

XTE Display

Der Herbst nähert sich - es gibt nur noch wenige Wochenenden zum Ausprobieren...
Daher hier nochmal eine neue Version, die jetzt auf der GPS Seite die Abweichung zum Kurs zeigt (XTE) - hatten wir irgendwie beim Test am Wochenende vermisst...
http://www.wellenvogel.net/software/avna…loads/index.php
index.php?page=Attachment&attachmentID=176527

Gruß Andreas

saltygoose

Super Moderator

Beiträge: 4 352

Schiffsname: Salty Goose

Bootstyp: Ganter 26

Heimathafen: Goose bay

Rufzeichen: Gack

  • Nachricht senden

99

Mittwoch, 3. September 2014, 23:41

Mal ganz kurz: Ich hab meinen PI reaktiviert, die Software (image) aufgespielt und wollte dann testen.
Als Wlan-Stick hatte ich erst einen Netgear WG111, wollte nicht funktionieren. Nach stundenlangen Versuchen (das muss doch gehen...) gab ich auf, habe mir einen aktuelle Zyxel-Stick in mini gekauft, reingesteckt, ging. Steckte ich den Netgear Adapter dazu, funktionierte keiner der Sticks.
Da ich aber gerne eine Bridge-Funktion hätte (Abgreifen und verteilen des Hafen-Wlans) liess mir das keine Ruhe.
Also den Alfa-Wlan Adapter drangehängt. Der wurde dann als eth0-Schnittstelle einsortiert, dafür ging die eigentliche eth0 nicht mehr.
Alles sehr merkwürdig. Nun ja, tagelang probiert.. umsonst.
Grad hab ich des Rätsels Lösung gefunden: Die Stromversorgung (handelsüblicher Ladeadapter) des Pi reicht nicht aus, um Sticks zu betreiben, die etwas mehr Saft ziehen. Sowohl der Netgear als auch der Alfa verwenden den rtl8781 Chip, der saugt halt.
Nachdem ich nun einen aktiven USB-Port mit großem Netzteil verwende, über den auch der PI gespeist wird, werden alle 3 (gleichzeitig vorhandenen) WLAN-Adapter erkannt. Nun kann ich daran gehen, die Bridge einzurichten. Damit sollte dann auch per Tethering über das Handy eine UMTS-Verbindung ins Netz möglich werden.
Fazit: An Bord sollte sich auch ein aktiver USB-Hub befinden, an den man die Peripherie hängt, der PI ist unglaublich sensibel was die Stromversorgung angeht.
:music: Es grüßt Frank :music:

praxis-spranger.de

jensstark

Salzbuckel

Beiträge: 8 258

Wohnort: Halstenbek

Schiffsname: Moi

Bootstyp: Dehler Optima 98GS

Heimathafen: Nestleweg 8, Kappeln

Rufzeichen: DB8094 / (DB9MOI)

  • Nachricht senden

100

Donnerstag, 4. September 2014, 00:09

An Bord sollte sich auch ein aktiver USB-Hub befinden

Da gibt es sogar nette für 12V-Versorgung und so. (Etwas überqualifiziert beispielsweise der Exsys EX-1184HMV.)

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 955   Hits gestern: 2 909   Hits Tagesrekord: 5 297   Hits gesamt: 4 528 039   Hits pro Tag: 2 343,61 
 Seitenaufrufe:   Klicks heute: 6 838   Klicks gestern: 21 481   Klicks Tagesrekord: 154 353   Klicks gesamt: 36 194 299   Klicks pro Tag: 18 733,33 

Kontrollzentrum