Sie sind nicht angemeldet.

Werbung

Boote kaufen

Windstärken

Windstärkentabelle

Hallo Besucher, willkommen im Segeln-Forum! Hier kannst Du Dich registrieren, um unser Forum in seiner vollen Pracht genießen zu können! - Weitere Infos zur Registrierung - Login für Mitglieder -

  • »norbert-walter« ist der Autor dieses Themas

Beiträge: 109

Wohnort: Düsseldorf

Schiffsname: Cumulus

Bootstyp: Dehlya 22

Heimathafen: Lemmer (NL)

  • Nachricht senden

181

Montag, 14. Mai 2018, 12:16

Hallo Jörg,

super, vielen Dank für die Info. Im Link ist ein Bild vom PeteBros- Sensor dabei. Genau den selben Fehler habe ich auch. Das ist der kritischte Punkt bei diesem Sensor. Die richtige Einstellung ist Erfahrungssache. Jetzt zeigt sich in der Serie wie sicher sich das umsetzen lässt. Im Oszibild sind die Aussetzer gut zu sehen. Ich muss mal schauen wie ich das hinbekomme. Das muss sicher funktionieren, damit die jenigen die das selber zusammenbauen wollen nicht an der Einstellung verzweifeln. Ich werde wohl in die Software einen Testmode mit einbauen müssen, so dass man sehen kann, ob die Sensoren korrekt schalten. Ich werde da heute noch ein wenig weitermachen. Das sind so typische Fehler bei der Entwicklung neuer Produkte. Wenn man vorher alles wüsste wäre es hinterher nicht so aufwändig. Die Lernkurve steigt! ;)

Norbert

@all:

Heute habe ich die Antwort aus China bekommen, dass sie die Teile fertigen und in 2 Wochen fertig sein sollen. Ich bin schon ganz gespannt.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »norbert-walter« (14. Mai 2018, 14:46)


  • »norbert-walter« ist der Autor dieses Themas

Beiträge: 109

Wohnort: Düsseldorf

Schiffsname: Cumulus

Bootstyp: Dehlya 22

Heimathafen: Lemmer (NL)

  • Nachricht senden

182

Dienstag, 15. Mai 2018, 22:45

@all:

Ich glaube ich habe eine Lösung für das Blendenproblem gefunden. Beim PeetBros-Windsensor haben sie die abschirmende Fläche seitlich vergrößert. Das ist bei mir nicht das Problem, da ich den halben Umfang mit Blech auskleide. Bei mir ist das Problem die Höhe des Blechs. Es reicht nicht tief genug herunter und in die Höhe. Testweise habe ich mal ein größeres Blech verwendet. Da schaltet der Sensor dann sicher. Bei dem kleinen Blech kann das Magnetfeld drum herum laufen und erreicht den Sensor weiterhin. Alternativ habe ich auch mal getestet das Blech außen herum zu legen. Damit konnte ich den Sensor auch sicher schalten. Problem ist nur, dass der Magnet dann sehr dicht am Blech ist und die Anziehngskraft so groß wird, dass er die Windfahne mitzieht. Es muss also ein guter Kompromiss zwischen Abstand des Blechs zum Magneten und der Größe des Blechs ermittelt werden. Morgen werde ich mir mal ein richtiges Blech anfertigen und im Windsensor testen. An den 3D-Teilen muss bis jetzt nichts geändert werden. Einzig die Größe des Abschirmblechs wurde geändert.

Dann habe ich auch mal meinen alten Windex zerlegt. Wie vermutet besteht er aus einer Kombination von Spitzenlager mit Saphirlagerung und einem Gleitlager aus Messing zur seitlichen Abstützung. So richtig leichtgängig ist der Windex aber auch nicht, da das Stütz-Gleitlager ausgenuddelt war und die Abstützung über die Kunststoffhülse lieft. Dort hatte sich die dünne Welle schon in den Kunststoff eingearbeitet. Der Messingring ist meines erachtens zu mah am Spitzenlager angebracht und müsste viel tiefer sitzen. Dann sind die Kräfte viel geringer auf das Gleitlager. Das ging vermutlich aus Fertigungsgründen nicht.

Norbert
»norbert-walter« hat folgende Dateien angehängt:

chrhartz

Offizier

Beiträge: 251

Wohnort: München

Bootstyp: Neptun 20

Heimathafen: Bernau, Chiemsee

  • Nachricht senden

183

Mittwoch, 16. Mai 2018, 10:43

Hallo Norbert,

haben sich die 3d-Teile nochmal geändert?

Ich habe die Daten am 17.04. heruntergeladen. Kann man schon anfangen zu drucken oder sind noch Änderungen zu erwarten?

Viele Grüße,
Christian
Neptun 20, Segelnummer 950, Honda 5BFU, Liegeplatz Bernau/Chiemsee

184

Mittwoch, 16. Mai 2018, 12:22

Moin,
sind die Sachen alle an einem Ort gespeichert? Samt Gerber Files und co.? Habt ihr mal einen Link?

Mal zu der Funktion der Windrichtung... wenn ich mir das System hier anschaue http://www.peetbros.com/shop/custom.aspx?recid=14 so ist der Windrichtungssensor in der Lage über 360° um ihn das Magnetfeld zu detektieren. Das Metallplättchen was sich mit dem Windgeschwindigkeitsmesser dreht, schirmt das Magnetfeld und ich kann über den Zeitlichen verlauf im Verhältnis zum Windgeschwindigkeitssensor den Winkelversatz ermitteln... führt dann am ende zu der Windrichtung.

Ich hoffe das habe ich soweit richtig verstanden...

Nun messen doch Hallsensoren das Feld in dem sie den "Drift von Elektroden bestimmen", brauchen also ja eigentlich eine bestimmte Richtung von wo das Feld sie Durchströmt... :O

https://www.udoo.org/docs-neo/Cookbook_A…all_Sensor.html


Grüße Malte

  • »norbert-walter« ist der Autor dieses Themas

Beiträge: 109

Wohnort: Düsseldorf

Schiffsname: Cumulus

Bootstyp: Dehlya 22

Heimathafen: Lemmer (NL)

  • Nachricht senden

185

Mittwoch, 16. Mai 2018, 13:56

@chrhartz:

Die CAD-Daten sind noch aktuell. Warte aber bitte bis heute Abend wenn ich den Windsensor mit der neuen Blende noch einmal teste. Dann würde ich das ok geben.

@the_muck:

Du hast es richtig beschrieben. Genau so wird es gemacht. Die Richtung des Magnetfeldes ist wichtig. Der Magnet nuss also richtig herum eingebaut werden, sonst funktioniert der Hallsensor nicht.

Norbert

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »norbert-walter« (16. Mai 2018, 16:58)


186

Mittwoch, 16. Mai 2018, 14:40

Hall Sensoren haben aber dann doch, die durch das Feld zu Beströmende Fläche um die Hall spannung zu erzeugen.

https://www.tme.eu/de/Document/7bd753978…nd%20SS445P.pdf

Seite 3.

Windsensor DIY

Wenn der Sensor wie auf dem Bild verbaut ist, verstehe ich noch nicht so recht wie die Feldlinien bei einer 360° Drehung die Fläche "Konstant" durchströmen. Der Arbeitspunkt wird dadurch doch sehr unpräzise und nicht sonderlich Prozesssicher...

Vielleicht kann man den Sensor legen und den Magnet mit einem U Blech schirmen... aber, wie du festgestellt hast, um so besser der Magnetische Kurzschluss / Schirmung um so größer die Kraft und das mitziehen...

Grüße Malte

  • »norbert-walter« ist der Autor dieses Themas

Beiträge: 109

Wohnort: Düsseldorf

Schiffsname: Cumulus

Bootstyp: Dehlya 22

Heimathafen: Lemmer (NL)

  • Nachricht senden

187

Mittwoch, 16. Mai 2018, 17:21

@the_muck:

Ja, das ist ein wenig tricky mit dem oberen Hallsensor. Da hab ich etwas recherchieren müssen, bis ich die Lösung hatte. Es gibt da verschiedene Typen wie:
  • unipolar switch, digital
  • bipolar switch, digital
  • bipolar latch, digital
  • onmipolar switch, digital
  • linear, analog
Für den oberen Hallsensor verwende ich einen omnipolaren Hallsensor. Das sind die Feldplatten anders angeordnet als beim unipolaren Hallsensor den ich für die Windgeschwindigkeit verwende. Vom Anschlußbild sind beide Sensoren gleich und benutzen einen Open- Kollektor- Ausgang mit einem Versorgungsspannungsbereich zwischen 3,0 und 24V. Daher funktioniert das mit dem umlaufenden senkrechten Magneten. Das ist dann quasi das elektronische Pendant zum Reed- Schalter. Ich hatte auch erst überlegt Reed-Schalter zu verwenden. Das habe ich aber dann verworfen, da mir die Teile zu groß waren. Die kleinsten Reed-Schalter die man standardmäßig bekommt sind D3x15mm. Die sind teilweise auch von der Empfindlichkeit unterschiedlich, wenn man sich außen herum bewegt. Da krankt der PeetBros-Sensor auch dran. Die omnipolaren Hallsensoren sind robuster, da sie mehrere Feldplatten verwenden. Unter folgendem Link ist der grundsätzliche Aufbau ganz gut beschrieben:

https://www.google.com/url?sa=t&rct=j&q=…5muS2Ac84Yzl0Dt
Norbert

188

Mittwoch, 16. Mai 2018, 21:14

Hallo,
mir geht es darum wie das Magnetfeld den Sensor durchströmt, das muss / sollte je sehr gleichmäßig über die 360° sein damit die "Magnetischen Blende" den gleichen Schaltabstand hat... Ich kenne die Sensoren nur so das sie je nach einfallenden Winkel der Feldlinien eine Unterschiedliche Hallspannung liefern, damit also andere Schaltschwellen... Je nach dem wo der Magnet also von der "Magnetischen Blende" abgeschirmt wird kann es also sein das der Sensor durch anders einfallende Feldlinien einen anderen Schwellwert zur Blende hat... Führt zu einem Messfehler...

Ich frage da so genau weil mir der Punkt beim verstehen des Konzeptes Probleme gemacht hat ;). Mit der Annahme das der Sensor über die 360° immer die selbe Schaltschwelle zur blende hat macht es sinn... Hast du denn da schon Messergebnisse wie genau das ist über 360° ? Theoretisch müsste man den Magneten ja nur auf einer Umlaufbahn kreisen lassen und den Abstand erhöhen und schauen wie die Schaltschwellen sind. Ich fragte mich halt warum du den sensor nicht kippst, gefühlt durchströmen die Feldlinien bei Vertikalem N/S Magneten den Sensor dann besser.

Grüße Malte

  • »norbert-walter« ist der Autor dieses Themas

Beiträge: 109

Wohnort: Düsseldorf

Schiffsname: Cumulus

Bootstyp: Dehlya 22

Heimathafen: Lemmer (NL)

  • Nachricht senden

189

Donnerstag, 17. Mai 2018, 13:37

Hallo Malte,

genau so teste ich den Magneten. Ich lasse ihn ohne Blende umlaufen und stelle ihn so ein, dass er in allen Winkelpositionen sicher schaltet (an ist). Dann baue ich die Blende (Schalenrad) ein und teste ebenfalls für jede Umdrehung ob er genau einmal einschaltet und einmal auschaltet. Der omnipolare Hallsensor hat eine Schaltschwelle die vom Magnetfeld abhängig ist. Der Sensor ist nicht in jedem Winkel gleich empfindlich, so dass die Schaltschwelle unterschiedlich ist. Es kann passieren, dass der Sensor mehr als einmal je Umdrehung schaltet. Dass darf natürlich nicht sein. Daher muss das Magnetfeld so abgeschirmt werden, dass es den Sensor nicht erreicht und immer unterhalb der Schaltschwelle bleibt. Nur mit einer einfachen Blende aus Weißblech ist das nicht sicher möglich. Das kann bei einem Modell funktionieren und bei einem anderen nicht (so wie bei mir jetzt :( ). So wie ich mir das gedacht hatte mit dem höheren Blech geht es leider auch nicht. Das hatte ich gestern noch getestet. Im Internet habe ich noch ein wenig rumrecherchiert und bin auf die Firma Sekels gestoßen. Die vertreiben Mumetall-Bleche mit hoher Permeabilität. Auf deren Webseite ist in einem Paper sehr schön beschrieben wie man eine magnetische Abschirmung wirklungsvoll realisiert.

https://www.sekels.de/fileadmin/PDF/Deut…schirmungen.pdf

Ich habe die Blende noch einmal modifiziert und dem Abschirmblech "Polschuhe" verpasst, so dass ich das Magnetfeld besser durch das Blech zwingen kann. das Grundprinzip der magnetischen Abschirmung beruht darauf, dass man Metalle mit hoher Permeabilität in die Nähe der Magnetquelle bringt die sehr gut das Magnetfeld durchleitet. Die Feldlinien konzentrieren sich dann im Abschirmblech. Die Enden sollten aber möglichst geschlossen sein. Das ist bei mir nicht der Fall. Daher habe ich Polschuhe angebracht die nahe am Magneten vorbeilaufen und das Magnetfeld "absaugen".

Ich stelle heute Abend noch ein Bild dazu ein. Da sieht man wie das realisiert ist. Mal sehen, wenn ich noch Zeit habe simuliere ich das mal mit FEMM. Da kann man den Feldverlauf sehr gut sichtbar machen. Die Bilder bei Sekels auf der Webseite wurden auch mit dem Programm gemacht. Das ist übrigens OpenSource. :)

Norbert

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »norbert-walter« (17. Mai 2018, 19:26)


190

Donnerstag, 17. Mai 2018, 13:48

Interessant. Ich habe mir zwar noch nie Gedanken gemacht, wie sowas gemessen wird aber jetzt fällt mir wieder ein, dass das der Lösung an meinem Fahrrad in den 80ern gleicht.

Aber ganz davon abgesehen. Gibt es für sowas keine fertigen Bauteile?! Evtl. auch integriert in einem Lager?

VG


"If you want to keep a secret, put it in the sailing instructions."
(Unbekannt)


chrhartz

Offizier

Beiträge: 251

Wohnort: München

Bootstyp: Neptun 20

Heimathafen: Bernau, Chiemsee

  • Nachricht senden

191

Donnerstag, 17. Mai 2018, 16:56

Hallo Norbert,

evtl. funktioniert auch Ferritfolie. Die setze ich beispielsweise unter drahtlose Ladespulen
um das Magnetfeld auf die Spule zu konzentrieren. Das wäre auf jeden Fall billiger als Permalloy oder Mu-Metall.

Du kannst auch einen alten Motor oder Trafo schlachten und von dort ein Blech nehmen. Auch das ist
besser als Weissblech.

Die flexiblen Magnete von Haftschildern wie man sie fürs Auto oder die Kühlschranktür verwendet,
funktionieren auch als Abschirmung. Die haben zwar selber eine magnetische Eigenschaft, die ist aber
hundsmiserabel weil sie alle paar Millimeter abwechselnd magnetisiert sind. Die Felder heben sich daher
gegenseitig auf.

Viele Grüße,
Christian
Neptun 20, Segelnummer 950, Honda 5BFU, Liegeplatz Bernau/Chiemsee

  • »norbert-walter« ist der Autor dieses Themas

Beiträge: 109

Wohnort: Düsseldorf

Schiffsname: Cumulus

Bootstyp: Dehlya 22

Heimathafen: Lemmer (NL)

  • Nachricht senden

192

Donnerstag, 17. Mai 2018, 17:13

@the_muck:

Im Grunde genommen sind im onmipolaren Hallsensor die Feldplatten gekippt angeordnet. Ich meine es sind auch mehrere verbaut um eine nahezu gleichmäßige Empfindlichkeit aus allen Richtungen zu erzielen. Einen normalen Sensor zu nehmen und den zu kippen ging nicht, da ich dafür keinen Platz habe. In der Aluhülse ist nur ein 4,1 mm Loch in das alles reinpassen muss. Die Hülse dient gleichzeitig als Auflage für die Kugellager. Prinzipiell scheint es ja auch zu gehen. Die Kunst ist halt wie man das Feld mit der Blende "umlenkt" und vom Hallsensor fernhält. Das gleiche Problem hast Du aber auch mit dem gekippten Sensor. Ich vermute mal schwer, dass die Blende das Magnetfeld stark verformt und an den spitzen Ecken der Blende unschönbe Feldverzerrungen auftreten, die die doppelten Impulse auslösen. Das muss nicht unbedingt am Sensor liegen. Daher würde ich es gerne simulieren wollen. Das sieht man die Feldverteilungen am besten.

@TrampMuc

Ich weiß nicht genau was Du mit "integriert in ein Lager" meinst?

@chrhartz:

Ferritfolie, Trafoblech oder die Haftfolie sind auch nicht schlecht. Ich hatte mit Mumetall aus einer Festplatte rumexperimentiert. Das hat die selben Probleme verursacht. Ich tippe stark drauf, dass die geometrische Form der Blende das Problem verursacht. Eventuell könnte man mal die Ecken runden. Ich werde das heute mal mit den "Polschuhen" testen.

  • »norbert-walter« ist der Autor dieses Themas

Beiträge: 109

Wohnort: Düsseldorf

Schiffsname: Cumulus

Bootstyp: Dehlya 22

Heimathafen: Lemmer (NL)

  • Nachricht senden

193

Donnerstag, 17. Mai 2018, 21:07

@chrhartz:

Ich habe gerde die Polschuhe ausprobiert. Es gibt immer noch die Aussetzer. Das Feld wird zwar ins Metall gelenkt. Die Windfahne wird aber zum Teil mitgezogen. Also doch keine so gute Idee.

Hier noch einmal die relative Permeabilität (µr) für einige Materialien:

Eisen 80...150
Ferritfolie 230
Trafoblech 400...650
Mumetall 12.000
Cr-Permalloy 12.000

Je höher die relative Permeabilität um so besser das Vermögen das Magnetfeld hindurchzuleiten. Ferritfolie und Trafoblech wären die ersten Testkandidaten. Mumetall ist vermutlich die beste Wahl. Das Mumetall was ich aus der Festplatte verwendet hatte (Deckplatte auf der Oberseite) war doch kein Mumetall. Es war irgend etwas anderes. Intern verwenden die Mumetall um den Magneten der Lesekopfmechanik zu halten und gleichzeitig abzuschirmen. Das Teil ist aber zu dick. Das bekomme ich nicht gebogen. Ist noch irgendwo anders Mumetall verbaut wo man es ausschlachten könnte? Von der Ferritfolie konnte ich Testmuster bei Würth bestellen. Alternativ müsste ich mal bei Sekels nachfragen, ob die mir auch ein Testmuster zusenden könnten.
»norbert-walter« hat folgende Dateien angehängt:

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »norbert-walter« (18. Mai 2018, 07:51)


chrhartz

Offizier

Beiträge: 251

Wohnort: München

Bootstyp: Neptun 20

Heimathafen: Bernau, Chiemsee

  • Nachricht senden

194

Sonntag, 20. Mai 2018, 14:02

Hallo Norbert,

bis Dein Sensor soweit ist, habe ich provisorisch meine Bluetooth-Windfahne montiert.

Mit dem Drucker habe ich eine Klemme gedruckt, mit der die Fahne an die vorhandene
7 mm Stange vom Windex montiert wird. Knapp darunter und nach vorne zeigend, dann sehe
ich die Fahne nicht. Ich will ja nicht den Windex verdecken.

Die Daten gehen dreimal pro Sekunde per Bluetooth Advertising an den Raspberry und
werden dort mit Node-Red verarbeitet. Wenn man erst einmal Noble nachinstalliert bekommen
hat, ist der Rest erstaunlich einfach.

So sieht das jetzt aus:










Auf Dauer möchte ich einen zweiten Screen beim Raspi einstellen, wo die ganzen Instrumente drauf sollen.
Dann wird die Anzeige auch hübscher, die eingebauten von OpenCPN sind sowas von grottenhässlich... ;)

Viele Grüße,
Christian
Neptun 20, Segelnummer 950, Honda 5BFU, Liegeplatz Bernau/Chiemsee

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 203   Hits gestern: 2 449   Hits Tagesrekord: 5 297   Hits gesamt: 3 676 883   Hits pro Tag: 2 343,61 
 Seitenaufrufe:   Klicks heute: 1 213   Klicks gestern: 18 445   Klicks Tagesrekord: 154 353   Klicks gesamt: 30 344 602   Klicks pro Tag: 19 341,35 

Kontrollzentrum

Helvetia