Sie sind nicht angemeldet.

Werbung

Boote kaufen

Windstärken

Windstärkentabelle

Hallo Besucher, willkommen im Segeln-Forum! Hier kannst Du Dich registrieren, um unser Forum in seiner vollen Pracht genießen zu können! - Weitere Infos zur Registrierung - Login für Mitglieder -

101

Freitag, 12. Oktober 2018, 16:54

Wow! Hast du mal irgendwo in der Qualitätssicherung gearbeitet 8o ? Nee, Spaß beiseite


Ich habe an Murphy eher gedacht ;)

Zitat


Im Image ist die avnav 20180313 Version drin, falls das hilft...

Danke. Habe nachgestellt. 20180313 Release schnell auf SD augespielt ... Alles nackt...halt vanilla.
Gestartet. Per SSH auf die RPI. Dann mein U-Blox und dAISy angeschlossen (hotplug). Nach ca. 1.5 Minuten kam GPS Fix. In der Weboberfläche 10 Sat verfügbar, 7 werden benutzt. Alles GUT

Quellcode

1
2
3
4
5
6
7
8
9
2018-10-12 13:13:38,298-486-[854]SerialReader-ttyACM1-/dev/ttyACM1-INFO-openDevice for port /dev/ttyACM1, baudrate=38400, timeout=1.000000, autobaud=true
2018-10-12 13:13:38,299-486-[664]AVNUsbSerialReader-INFO-started reader for anonymous device  ttyACM1 at /dev/ttyACM1
2018-10-12 13:13:38,305-486-[855]SerialReader-ttyACM0-/dev/ttyACM0-INFO-openDevice for port /dev/ttyACM0, baudrate=38400, timeout=1.000000, autobaud=true
2018-10-12 13:13:38,306-486-[664]AVNUsbSerialReader-INFO-started reader for anonymous device  ttyACM0 at /dev/ttyACM0
2018-10-12 13:13:38,896-486-[854]SerialReader-ttyACM1-/dev/ttyACM1-INFO-autobaud successfully finished at baud 38400
2018-10-12 13:13:38,902-486-[854]SerialReader-ttyACM1-/dev/ttyACM1-INFO-successfully opened /dev/ttyACM1
2018-10-12 13:14:52,380-486-MainThread-INFO-new GPS fix lat=5x.988633 lon=y.493690, time=2018-10-12T13:16:05.000Z, currentTime=2018-10-12T13:14:52.379966
2018-10-12 13:14:52,383-486-MainThread-WARNING-detected UTC time diff between system time 2018-10-12T13:14:52.379966 and gps time 2018-10-12T13:16:05, setting system time
2018-10-12 13:14:52,384-486-MainThread-INFO-starting command /usr/lib/avnav/raspberry/settime.sh 101213162018.05

Tja. Jetzt würde mich interessieren wie und was @noopd falsch macht.
»BlackSea« hat folgende Datei angehängt:

102

Samstag, 13. Oktober 2018, 07:58

@noopd
ich glaube dass ich die Lösung gefunden habe. Ich bräuchte aber paar Infos
1. Dein AIS Stick ist ein SEANEXX ( wenn ich richtig im Gedächtnis habe)?
2. In OpenCPN benutzt du das Stick mit 115200 bauds?

Wenn das stimmt, ich habe schon ein Pull Request bei @wellenvogel eröffnet
Die Frage ist jetzt wie wir diese Änderung bei dir einspielen können. Schaffst du per SSH auf RPI zu verbinden und eine Datei editieren?

noopd

Lichtmaschinenerklärbär

Beiträge: 599

Wohnort: Krefeld

Schiffsname: Last Boy Scout

Bootstyp: Dehler Optima 106

Heimathafen: Workum

Rufzeichen: DG8965

MMSI: 21179450

  • Nachricht senden

103

Montag, 15. Oktober 2018, 00:51

Das ist mein Stick.
NMEA 0183 38400 SendeCODE im Bild


Editieren von Dateien sollten mit einigen "Anleitungen" möglich sein. ;( Bilder einmal nur Stick mit GPS-Signal und mit GPS-Signal vom Tablet mit OpenCPN Verbindung über AVNav-WLAN, dann MIT Anzahl der Satelliten.
»noopd« hat folgende Dateien angehängt:
Wenn Du wissen willst, wer dich beherrscht, musst Du nur herausfinden, wen Du nicht kritisieren darfst (Voltaire).

pandel

Proviantmeister

  • »pandel« ist der Autor dieses Themas

Beiträge: 349

Wohnort: Moers

Schiffsname: Haihappen

Bootstyp: Leisure 17

Heimathafen: Jachhaven De Driesen

Rufzeichen: DF7978

  • Nachricht senden

104

Montag, 15. Oktober 2018, 08:49

@BlackSea:
@noopd:

...
Wenn das stimmt, ich habe schon ein Pull Request bei @wellenvogel eröffnet
Die Frage ist jetzt wie wir diese Änderung bei dir einspielen können. Schaffst du per SSH auf RPI zu verbinden und eine Datei editieren?

Nur so als Tipp: man kann problemlos von Windows aus bspw. mit WinSCP (SSH) auf den RPi zugreifen und die Datei einfach austauschen. Dann bleibt dem Ungeübten das Rummfummeln mit vi oder nano erspart...

105

Montag, 15. Oktober 2018, 08:57

Zitat


Das ist mein Stick.
NMEA 0183 38400 SendeCODE im Bild

Dann doch nicht was ich vermutet habe. In wirklichkeit dein AIS/GPS sendet sehr reduziertes NMEA Satz. Genauer gesagt nur RMC. Diese Satz beinhaltet keine daten über Verfügbare und Benutzte Sateliten. Tja
Mögliche Abhilfe: Stick manuell ( kein Autodetect! ) mit Filter nur für AIVDM Daten konfigurieren, dazu ein "08/15" GPS Stick kaufen z.B. VK-172 und dann wird alles gut

Beiträge: 11

Wohnort: Bremen

Bootstyp: Leisure 23

Heimathafen: Bremen

  • Nachricht senden

106

Freitag, 4. Januar 2019, 23:02

Aloha erstmal und mein erster "Post" denke ich !

Ich hab alles soweit hinbekommen ausser RTL_AIS unten links im Browser roter Button AIS:0 targets

Also gehe ich davon aus das es nicht läuft aber im Server Status steht ......mainreceiving 127.0.0.1:10110

und nach ca. 5 sek .......mainsocket to 127.0.0.1:10110 disconnected dann hab ich im Log nachgeschaut unter

/avnav/data/log$ sudo nano avnav.log.2019-01-03


2019-01-03 05:39:13,264-522-[863]AVNNmeaLogger-INFO-compressing nmea log /home/pi/avnav/data/tracks/2018-06-24.nmea
2019-01-03 05:39:13,878-522-[849]SocketReader-127.0.0.1:10110-INFO-exception while trying to connect to 127.0.0.1:10110 Traceback (most recent call last):
File "/usr/lib/avnav/server/handler/socketreader.py", line 102, in run
sock=socket.create_connection((self.getStringParam('host'),self.getIntParam('port')), self.getIntParam('timeout'))
File "/usr/lib/python2.7/socket.py", line 575, in create_connection
raise err
error: [Errno 111] Connection refused


lsusb = Bus 001 Device 007: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T Im Windows Rechner nur RTL2832


pi@raspberrypi:~$ rtl_test
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.


Woran kann das liegen ich finde nichts. Ich hab die Version 06 geflasht

vielen dank schon mal im vorraus
»sirreiner« hat folgende Datei angehängt:
  • AIS.png (2,1 kB - 233 mal heruntergeladen - zuletzt: 20. Mai 2019, 07:02)

107

Samstag, 5. Januar 2019, 07:08

als erstes: avnav versucht sich mit dem port 10110 zu verbinden. Es läuft/lauscht da kein Process
Prüfung

Quellcode

1
netstat -nl | grep 10110


Stützig macht auch dein test

Zitat


usb_claim_interface error -6
Failed to open rtlsdr device #0.


Hast du generell dein RTL konfiguriert?

Beiträge: 11

Wohnort: Bremen

Bootstyp: Leisure 23

Heimathafen: Bremen

  • Nachricht senden

108

Samstag, 5. Januar 2019, 07:37

Guten morgen

Da kommt nichts an oder ?

pi@raspberrypi:~$ netstat -nl | grep 10110
tcp 0 0 0.0.0.0:10110 0.0.0.0:* LISTEN
pi@raspberrypi:~$ sudo netstat -nl | grep 10110
tcp 0 0 0.0.0.0:10110 0.0.0.0:* LISTEN

Server Status
Hab ich auch noch diese Fehlermeldung

AVNUsbSerialReader

SerialReader-1-1.3:1.0-/dev/ttyUSB0unable to open port
Ich hab in der Datei /etc/modprobe.d$......raspi-blacklist.conf diese Zeilen drin
blacklist dvb_usb_rtl28xxu
blacklist dvb_usb_v2
blacklist rtl_2830
blacklist rtl_2832
blacklist r820t

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »sirreiner« (5. Januar 2019, 08:03)


109

Samstag, 5. Januar 2019, 07:52

hm... Es läuft doch da was

Zitat


Quellcode

1
2
pi@raspberrypi:~$ netstat -nl | grep 10110
tcp 0 0 0.0.0.0:10110 0.0.0.0:* LISTEN



mach mal

Quellcode

1
nc 127.0.0.1 10110


um zu ermitteln was für process den Port belegt

Quellcode

1
netstat -nlp | grep 10110

Beiträge: 11

Wohnort: Bremen

Bootstyp: Leisure 23

Heimathafen: Bremen

  • Nachricht senden

110

Samstag, 5. Januar 2019, 08:12

pi@raspberrypi:~$ netstat -nlp | grep 10110
(Es konnten nicht alle Prozesse identifiziert werden; Informationen über
nicht-eigene Processe werden nicht angezeigt; Root kann sie anzeigen.)
tcp 0 0 0.0.0.0:10110 0.0.0.0:* LISTEN -
pi@raspberrypi:~$ sudo netstat -nlp | grep 10110

tcp 0 0 0.0.0.0:10110 0.0.0.0:* LISTEN 325/rtl_ais
bei nc 127.0.0.1 10110 passiert nichts

Beiträge: 11

Wohnort: Bremen

Bootstyp: Leisure 23

Heimathafen: Bremen

  • Nachricht senden

112

Samstag, 5. Januar 2019, 11:27

/etc/ude/rules.d/71-rtl-sdr.rules

Quellcode

1
2
https://pandel.github.io/avnavtouch/Einbindung-eines-neuen-RTL-SDR-Receivers-via-udev.html
/etc/ude/rules.d/71-rtl-sdr.rules 

bei ude fehlt das " v " hab ich berücksichtigt

da mein USB stick die selbe Vendor und Produkt ID hat hab ich da nichts gemacht. Ich hab jetzt mal was bei Kal -s900 empfangen

Quellcode

1
2
3
4
5
6
kal: Scanning for GSM-900 base stations.
GSM-900:
chan: 81 (951.2MHz + 8.184kHz) power: 226219.28
pi@raspberrypi:~$ sudo kal -c81
Found 1 device(s):
0: Generic RTL2832U OEM

Ist ja schon ein bischen lau (Power:226219,28)
sudo kal -c81 hat mir keine Ausgebe gebracht......Ich hab ca. 30min gewartet.
Eigentlich hat der Stick 4 PPM zumindest hatte ich das schonmal als Ausgabe

Ich werde mal AVNAV flashen und dann mit einer anderen Anleitung versuchen dem USB - Stick was zu entlocken oder ein einfaches stretch und dort nur den Stick anhängen und SDR installieren

Beiträge: 11

Wohnort: Bremen

Bootstyp: Leisure 23

Heimathafen: Bremen

  • Nachricht senden

113

Donnerstag, 10. Januar 2019, 23:49

NooElec

So NooElec ist bestellt, ich hoffe das läuft auch auf dem Raspi 3 B.

Ich melede mich :D

Beiträge: 11

Wohnort: Bremen

Bootstyp: Leisure 23

Heimathafen: Bremen

  • Nachricht senden

114

Samstag, 12. Januar 2019, 16:08

Wenn man fast alles richtig macht

So ich hab den Stick und kaum das die richtige Hardware eingesetzt wird geht auch schon fast alles. (AVNAV-Touch)

Auf dem PC übers Netzwerk IP 192.168.30.10:8080 habe ich keine AIS Ziele. Aber auf dem Handy mit der avNav App hab ich 11 Ziele.
Kann man da noch was einstellen, Ich finde nichts?
»sirreiner« hat folgende Dateien angehängt:

115

Samstag, 12. Januar 2019, 17:45

Du kannst den Radius einstellen, in dem Ziele angezeigt werden.
Scheint aber zu passen.
Was sagt denn die Status-Seite?

116

Dienstag, 15. Januar 2019, 20:07

Hallo
ich dachte ich hänge mich mal hier dran. Ich habe zwar nicht das tolle avnavtouch aber dafür ein Problem mit dem nooelec rtl_sdr stick.


Was bisher geschah...
Ich habe avnavtouch ausprobiert (zu Hause im Garten) - war super. Ich habe den nooelec gekauft - war immer noch super, hat alles funktioniert.

Dann habe ich versucht Andres' letztes image zu installieren (ging nicht, weil raspberry pi 3 b+), also zurück zu avnavtouch. Neustes daly build von Andreas installiert, hat avnavtouch (zumindest den touch teil) zerschossen. War mir eigentlich egal, weil ich sowieso kein Display habe.

In der zwischen Zeit hat es BlackSea ein build von avnav für raspberry pi 3 b+ gebaut und mich gebeten das zu testen (siehe hier: Raspberry Pi als Bordcomputer - Spielzeug für den Winter )
Ich also drauf los getestet, alles super, bis auf AIS. Also geguckt was los ist, bis mir auffiel, dass da der rtl_sdr ais teil fehlt. Jetzt hatte mich der Ehrgeiz aber gepackt. Deshalb also selbst kompiliert und entsprechend eingebaut (wie hier beschrieben: avnav Touch - Raspberry Pi 3 (inkl. B+) mit 7'' Touchscreen als Plotter (geht aber auch wie gewohnt headless;-) ) )
Hier ein wenig Info:

Quellcode

1
2
~ $ lsusb
Bus 001 Device 004: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T

Quellcode

1
2
$ sudo netstat -nlp | grep 10110
tcp    	0  	0 0.0.0.0:10110       	0.0.0.0:*           	LISTEN  	305/rtl_ais

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
~ $ sudo /usr/local/bin/rtl_ais -n -g 30 -T -p 1
Edge tuning disabled.
DC filter enabled.
RTL AGC disabled.
Internal AIS decoder enabled.
Buffer size: 163.84 mS
Downsample factor: 64
Low pass: 25000 Hz
Output: 48000 Hz
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Detached kernel driver
Found Rafael Micro R820T tuner
Log NMEA sentences to console ON
Tcp listen port 10110
Ais message timeout with 15
Tuner gain set to 29.70 dB.
Tuner error set to 1 ppm.
Tuned to 162000000 Hz.
Sampling at 1600000 S/s.

Das Ding ist, dass avnav bei AIS rot ist, also gehe ich davon aus, dass da irgendwie nichts ankommt.

Die Anpassung des Frequenzoffsets habe ich mir gespart (weil der Nooelec so geil ist :D). Der Parameter -p steht also auf 1.
Hat jemand eine Idee?
Lg.
Nic

117

Mittwoch, 16. Januar 2019, 05:09

wenn "rtl_ais" dir die Daten liefert (prüf mal mit netcat/telnet) aber in avnav bleibt "AIS" rot und es ist nicht "touch" image. Würde ich vermuten dass dir ein reader in konfiguration fehlt

Quellcode

1
<AVNSocketReader  host="127.0.0.1" port="10110" />

118

Mittwoch, 16. Januar 2019, 07:13

Der SocketReader war schon mal ein guter Tip - der fehlte nämlich auch. Die frage ist jetzt nur noch, ob der rot bleibt, weil er keine Daten empfängt, oder ob immer noch irgendwas fehlt....

119

Mittwoch, 16. Januar 2019, 08:36

Was sagt die status Seite?
Dazu dann noch das log file....

120

Mittwoch, 16. Januar 2019, 09:28

Es scheint so zu sein, dass bei dieser Lösung ais rot ist, wenn nichts empfangen wird (im Januar AIS testen ist eine Herausforderung).
Ich hab mal alles mit nach Sønderborg genommen. Hier empfange ich dank der dänischen Marine einige Daten. Der Socket Reader ist mittlerweile auch auf der Status Seite aufgetaucht...
Vielen Dank für den Support:)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Nicolasb183« (16. Januar 2019, 11:46)


Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 259   Hits gestern: 2 601   Hits Tagesrekord: 5 297   Hits gesamt: 4 594 683   Hits pro Tag: 2 344,33 
 Seitenaufrufe:   Klicks heute: 1 393   Klicks gestern: 18 467   Klicks Tagesrekord: 154 353   Klicks gesamt: 36 627 943   Klicks pro Tag: 18 688,58 

Kontrollzentrum

Sailsquare

Mitsegler finden bei Sailssquare