Sie sind nicht angemeldet.

usprenger

Leichtmatrose

Beiträge: 35

Wohnort: OWL / Wetterau

Schiffsname: Hexe

Bootstyp: Bavaria 300

  • Nachricht senden

941

Montag, 27. April 2020, 18:28


Das Video schaue ich mir mal an, die restlichen Basteleien wieder in 14 Tagen, bin jetzt erstmal auf Baustelle.
Grüsse von der Hexe

Ulli

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »usprenger« (27. April 2020, 18:43)


Rheingauer

Leichtmatrose

Beiträge: 46

Wohnort: Eltville am Rhein

Bootstyp: Bavaria 33 Cruiser

Heimathafen: Lelystad

  • Nachricht senden

942

Sonntag, 3. Mai 2020, 10:18

Image 2020-04-01

Hallo Blacksea,
kann es sein, dass in dem aktuellen Release Image 20200401 der Avnav vom 20200330 steckt? Gehört das so, oder einfach die Avnav Version vom 20200401 darüber installieren?
Gruß Thomas

943

Sonntag, 3. Mai 2020, 11:48

Hallo Rheingauer,

ja, ist alles richtig. Image wurde am 01.04 gebaut
mit commit https://github.com/wellenvogel/avnav/com…f40b188c841b0df

Du kannst immer mit "sudo apt update && sudo apt -y upgrade" aktuell das System halten.

944

Montag, 4. Mai 2020, 12:56

Hallo Andreas

Ich habe Schwierigkeiten den Layout-Editor aufzurufen. Ich finde in den Einstellungen den Button dafür nicht. Was mache ich falsch?

  • »wellenvogel« ist der Autor dieses Themas

Beiträge: 976

Wohnort: Bernau

Schiffsname: Quetzal

Bootstyp: Contest 28

Heimathafen: Ueckermünde

  • Nachricht senden

945

Montag, 4. Mai 2020, 16:49

Welche Version hast Du denn?
Der Editor geht ab 20200325.
Hast Du mal einen Blick auf das Video aus 937 geworfen?

946

Samstag, 9. Mai 2020, 09:48

Hi

Ich hab ne avnav Version von letztem Jahr auf einem Pi 3 + model B. Ich habe irgendwo gelesen (ich glaube bei GitHub), dass man avnav jetzt auch per update/upgrade auf die nächste Version bringen kann.

Kann ich das schon bei meiner Version von letztem Jahr, oder ist es besser ein neues Image zu installieren?

Gruß

Nic

Gesendet von meinem GM1900 mit Tapatalk

947

Samstag, 9. Mai 2020, 12:31

Kann ich das schon bei meiner Version von letztem Jahr, oder ist es besser ein neues Image zu installieren?


Image aus letztem Jahr bei dir ist vermutlich noch ein Raspbian 9.x Stretch ( kannst du checken mit "cat /etc/issue.net")
Da kannst du noch händisch release deb runterladen und einspielen


Wenn du alle neue "goodies" (NMEA2000, SignalK, usw) benutzen möchtest, dann solltest du schon neuen Image installieren

948

Sonntag, 10. Mai 2020, 20:37

Hi BlackSea
ich habe beschlossen AVnav mit deinem letzten Image neu aufzusetzen (2020-04-01-avnav.zip).

Das update gibt aber einige errors aus - ist das so gewollt, oder muss ich das daily repo hinzufügen (deb https://open-mind.space/repo/ buster-daily avnav)?

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
sudo apt-get update
Ign:1 https://www.free-x.de/debian buster InRelease
Get:2 http://archive.raspberrypi.org/debian buster InRelease [25.2 kB]                                                                   	
Get:3 https://deb.nodesource.com/node_10.x buster InRelease [4,584 B]                                                                    	
Get:4 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]                                                                	
Ign:5 https://open-mind.space/repo buster-stable InRelease                                                                               	
Err:6 https://www.free-x.de/debian buster Release                                                                                        	
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses not yet valid certificate.  Could not handshake: Error in the certificate verification. [IP: 195.201.226.168 443]
Err:7 https://open-mind.space/repo buster-stable Release
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses not yet valid certificate.  Could not handshake: Error in the certificate verification. [IP: 5.146.2.141 443]
Reading package lists... Done              	
E: The repository 'https://www.free-x.de/debian buster Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://open-mind.space/repo buster-stable Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Release file for https://deb.nodesource.com/node_10.x/dists/buster/InRelease is not valid yet (invalid for another 12d 1h 49min 23s). Updates for this repository will not be applied.
E: Release file for http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease is not valid yet (invalid for another 39d 6h 1min 35s). Updates for this repository will not be applied.
E: Release file for http://archive.raspberrypi.org/debian/dists/buster/InRelease is not valid yet (invalid for another 37d 8h 31min 13s). Updates for this repository will not be applied.

Übrigens immer noch ein riesen Dankeschön an alle, die entwickeln- es macht wirklich Spaß mit AVnav;-)Nic

  • »wellenvogel« ist der Autor dieses Themas

Beiträge: 976

Wohnort: Bernau

Schiffsname: Quetzal

Bootstyp: Contest 28

Heimathafen: Ueckermünde

  • Nachricht senden

949

Sonntag, 10. Mai 2020, 20:47

Sieht nach einem Dateum/Zeit Problem aus...
Kannst Du mal die Zeit auf Deinem Pi auf ein aktuelles Datum stellen?
Wir haben standardmässig ntp aus (hat man ja unterwegs meist nicht).

950

Sonntag, 10. Mai 2020, 21:03

Hi

vielen Dank für die schnelle Antwort. Hab es mit raspi-config und auch über dpkg-reconfigure tzdata versucht...

Quellcode

1
2
3
4
5
6
7
pi@avnav:~ $ sudo dpkg-reconfigure tzdata

Current default time zone: 'Europe/Berlin'
Local time is now:  	Wed Apr  1 13:36:35 CEST 2020.
Universal Time is now:  Wed Apr  1 11:36:35 UTC 2020.

pi@avnav:~ $

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
pi@avnav:~ $ ifconfig 
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    	inet 192.168.2.27  netmask 255.255.255.0  broadcast 192.168.2.255
    	inet6 fe80::ba27:ebff:fecc:d774  prefixlen 64  scopeid 0x20<link>
    	inet6 fd00::ba27:ebff:fecc:d774  prefixlen 64  scopeid 0x0<global>
    	ether b8:27:eb:cc:d7:74  txqueuelen 1000  (Ethernet)
    	RX packets 8109  bytes 3405478 (3.2 MiB)
    	RX errors 0  dropped 0  overruns 0  frame 0
    	TX packets 4785  bytes 556778 (543.7 KiB)
    	TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    	inet 127.0.0.1  netmask 255.0.0.0
    	inet6 ::1  prefixlen 128  scopeid 0x10<host>
    	loop  txqueuelen 1000  (Local Loopback)
    	RX packets 7159  bytes 841991 (822.2 KiB)
    	RX errors 0  dropped 0  overruns 0  frame 0
    	TX packets 7159  bytes 841991 (822.2 KiB)
    	TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan-ap: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    	inet 192.168.30.10  netmask 255.255.255.0  broadcast 192.168.30.255
    	inet6 fe80::ba27:ebff:fe99:8221  prefixlen 64  scopeid 0x20<link>
    	ether b8:27:eb:99:82:21  txqueuelen 1000  (Ethernet)
    	RX packets 9056  bytes 944354 (922.2 KiB)
    	RX errors 0  dropped 26  overruns 0  frame 0
    	TX packets 8962  bytes 5141772 (4.9 MiB)
    	TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Vorschläge?
Nic

951

Sonntag, 10. Mai 2020, 21:31

Die Zeitzone war schon von anfang an Europe/Berlin. Das wird dir nicht helfen
Versuch sowas

Quellcode

1
sudo date +%Y%m%d%H%M -s "202005102130"

952

Sonntag, 10. Mai 2020, 21:41

Hat mit

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
sudo systemctl unmask ntp
sudo systemctl enable ntp
sudo systemctl restart ntp

sudo systemctl restart ntp
sudo dpkg-reconfigure tzdata

Current default time zone: 'Europe/Berlin'
Local time is now:  	Sun May 10 21:09:51 CEST 2020.
Universal Time is now:  Sun May 10 19:09:51 UTC 2020.

sudo systemctl mask ntp
Created symlink /etc/systemd/system/ntp.service → /dev/null.

geklappt:-)

  • »wellenvogel« ist der Autor dieses Themas

Beiträge: 976

Wohnort: Bernau

Schiffsname: Quetzal

Bootstyp: Contest 28

Heimathafen: Ueckermünde

  • Nachricht senden

953

Montag, 11. Mai 2020, 11:03

NTP dauerhaft zu aktivieren ist nicht unbedingt gut. Das könnte sich mit dem Setzen der Systemzeit über NMEA beissen.
Ein einfaches

Quellcode

1
sudo date -s 2020/05/11

würde genügen - muss ja nur im Moment mal aktuell sein. Zeitzone ist zwar nett - aber nicht so entscheidend.

Beiträge: 88

Wohnort: Barzano' (LC) - Italy

Schiffsname: Trekka

Bootstyp: Vela

Heimathafen: Mandello del Lario - Lago di Como - Italy

  • Nachricht senden

954

Montag, 11. Mai 2020, 11:56

Raspberry Pi come computer di bordo - giocattoli per l'inverno

Ciao @Blacksea, a question. Can I install AVnav on RP4 where Openplotter runs? If yes, can you give me the link for easy installation?
Thanks in advance and good wind, always! :rolleyes:

955

Montag, 11. Mai 2020, 12:17

Hi @Max1947:

yes, it's possible. e-sailing has already done its job to integrate AvNav into OP2. It is not yet an official part of OP2 but you can test it in advance
https://github.com/e-sailing/openplotter-avnav

Hope I didn't give too much away. :O

  • »wellenvogel« ist der Autor dieses Themas

Beiträge: 976

Wohnort: Bernau

Schiffsname: Quetzal

Bootstyp: Contest 28

Heimathafen: Ueckermünde

  • Nachricht senden

956

Montag, 11. Mai 2020, 13:36

We are just hoping to get it integrated in the near future.
Maybe it would speed up things if people ask them....
For now - as BlackSea wrote....

957

Montag, 11. Mai 2020, 17:44

Zitat

NTP dauerhaft zu aktivieren ist nicht unbedingt gut. Das könnte sich mit dem Setzen der Systemzeit über NMEA beissen.
Ein einfaches

Quellcode

1
sudo date -s 2020/05/11

würde genügen - muss ja nur im Moment mal aktuell sein. Zeitzone ist zwar nett - aber nicht so entscheidend.
Hmm

Aber es war doch von Anfang an deaktiviert.

Soll ich es wieder aktivieren?

LG.

Nic

Gesendet von meinem GM1900 mit Tapatalk

958

Montag, 11. Mai 2020, 20:21

Aber es war doch von Anfang an deaktiviert.

Soll ich es wieder aktivieren?


hauptsache, dass du das wieder deaktiviert hast.

Beiträge: 88

Wohnort: Barzano' (LC) - Italy

Schiffsname: Trekka

Bootstyp: Vela

Heimathafen: Mandello del Lario - Lago di Como - Italy

  • Nachricht senden

959

Dienstag, 12. Mai 2020, 18:56

Raspberry Pi als Bordcomputer - Spielzeug für den Winter

I asked Sailoog to integrate AvNav into OP-2, in the meantime @BlackSea can you tell me step by step how to insert it in OP. Sorry but for me it's a bit complicated! Thanks and sorry again.

See: http://forum.openmarine.net/showthread.php?tid=2566

Rheingauer

Leichtmatrose

Beiträge: 46

Wohnort: Eltville am Rhein

Bootstyp: Bavaria 33 Cruiser

Heimathafen: Lelystad

  • Nachricht senden

960

Mittwoch, 13. Mai 2020, 13:50

NMEA Logfile wird nicht geschrieben

Ich bin mit dem aktuellen Image vom 1.4.2020 zu Gange und habe nun festgestellt, dass scheinbar das nmea Logfile nicht geschrieben wird.

- Habe die Konfiguration noch mal auf Default geändert (ich würde gerne Wind aufzeichnen mit <AVNNmeaLogger filter=" $RMC,$MWV,$HDG"/>), aber auch da kein Erfolg.
- Test sowohl via RS232 also auch via TCP/IP, allerdings verwende ich eine Demoumgebung mit NMEA Daten vom letzten Jahr.
- Das Track File (.avt) wird korrekt geschrieben

Bei der letzen Version die ich verwendet habe, ging das Aufzeichnen im Default, mit dem Eintrag wie oben auch die Wind- und Heading Daten. Habe ich was falsch konfiguriert oder ist das möglicherweise ein Fehler?

Gruß
Thomas

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 1 858   Hits gestern: 3 342   Hits Tagesrekord: 12 076   Hits gesamt: 6 549 430   Hits pro Tag: 2 468,47 
 Seitenaufrufe:   Klicks heute: 11 409   Klicks gestern: 20 842   Klicks Tagesrekord: 154 353   Klicks gesamt: 49 537 486   Klicks pro Tag: 18 670,61 

Kontrollzentrum