Diese Webseite verwendet Cookies. Durch die Nutzung der Webseite stimmst Du der Verwendung von Cookies zu. Datenschutzinformationen [x]

Sie sind nicht angemeldet.

Werbung

Boote kaufen

Windstärken

Windstärkentabelle

Hallo Besucher, willkommen im Segeln-Forum! Hier kannst Du Dich registrieren, um unser Forum in seiner vollen Pracht genießen zu können! - Weitere Infos zur Registrierung - Login für Mitglieder -

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

1

Mittwoch, 25. März 2020, 19:36

Probleme mit rpi und daisy Hat installation

Ich dreh bald durch.
Ich bin nun wirklich nicht der Fachmann, gehe aber davon aus, das - wenn ich nach der Beschreibung installiere, funktioniert das auch.
Aber NIX.
Bild 1 - so sollte es aussehen
Bild 2(folgt) -so sieht es bei mir aus
Bei den folgenden Eingaben gibt es dann auch nicht das gewünschte Ergebnis.
Wo liegt der/mein Fehler?
»pepeldiver« hat folgende Datei angehängt:
Wasser ist nass 8o

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

2

Mittwoch, 25. März 2020, 19:49

Bild 2
»pepeldiver« hat folgende Datei angehängt:
Wasser ist nass 8o

sadmi

Smutje

Beiträge: 13

Bootstyp: Segelboot

Heimathafen: Yerseke

  • Nachricht senden

3

Mittwoch, 25. März 2020, 21:13

Hi,

ich kenne das Hat nur aus beschreibungen. Verbaut habe ich noch keins. Kenne mich aber mit Linux aus und das erste bild scheint mir nur die Hilfe zum daisy zu sein. Du bekommst also angezeigt welche Schalter du zu setzen hast um das Hat in einen bestimmten Zustand zu versetzen. Z.B. befehl zum ausführen des hat mit schalter 0 = daisy arbeitet mit serial 4800 baud.
Bild 2 zeigt doch nur ein Verzeichnis. Die letzte Zeile ist auch kein befehl zum starten eines Programms . Keine mir bekannte Syntax.
Solltest du auf den Pi mit openplotter arbeiten möchte ich mit sicherheit behaupten dass das daisy dort automatisch eingebunden wurde. Mal in den Nmea Einstellungen nachschauen.
Grundsätzlich ist dein Input aber bisschen dürftig und auch nicht ganz so einfach aus der ferne zu helfen.

Stefan

4

Mittwoch, 25. März 2020, 21:19

Hm...Wieso sind heute so gereizt? ?(

ich würde sagen dass du das kommando falsch abgetippt hast...

Quellcode

1
screen /dev/serial0 38400


Leerzeichen zwischen screen devicename geschwindigkeit

sadmi

Smutje

Beiträge: 13

Bootstyp: Segelboot

Heimathafen: Yerseke

  • Nachricht senden

5

Mittwoch, 25. März 2020, 21:37

Hm...Wieso sind heute so gereizt? ?(

ich würde sagen dass du das kommando falsch abgetippt hast...

Quellcode

1
screen /dev/serial0 38400


Leerzeichen zwischen screen devicename geschwindigkeit


Stimmt. Das macht dann Sinn und Bild 1 ist nicht die Hilfe sonder vermutlich ein Configmodul zum Hat.

6

Mittwoch, 25. März 2020, 21:41

ist halt menu....wenn du im "screen" dann ESC taste drückst

sadmi

Smutje

Beiträge: 13

Bootstyp: Segelboot

Heimathafen: Yerseke

  • Nachricht senden

7

Mittwoch, 25. März 2020, 21:59

ist halt menu....wenn du im "screen" dann ESC taste drückst


Möchte das Thema jetzt nicht kaputt machen erlaube mir aber eine Frage. Hast du erfahrungen mit den Hat. Liebäugle mit den externen Daisy. Arbeite seit 2 Jahren mit RTL also dvbt stick. Pi dann nur als Nmea Bridge, finde openplotter nicht so toll. Grundsätzlich zufrieden mit AIS aber wenn man dann wirklich mal den verkehr im Auge behalten wollte ist der blöde Stick wegen überhitzung abgeraucht. Deswegen auch kein Interesse an das Hat sondern an das externe Teil.

Stefan

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

8

Mittwoch, 25. März 2020, 22:20

Danke erst mal für die Antworten.

screen / dev / serial0 38400 (so aus der Beschreibung kopiert)

Ich versuche es morgen mal ohne Leerzeichen.

Jürgen
Wasser ist nass 8o

9

Mittwoch, 25. März 2020, 22:37

Hast du erfahrungen mit den Hat. Liebäugle mit den externen Daisy. Arbeite seit 2 Jahren mit RTL also dvbt stick. Pi dann nur als Nmea Bridge, finde openplotter nicht so toll. Grundsätzlich zufrieden mit AIS aber wenn man dann wirklich mal den verkehr im Auge behalten wollte ist der blöde Stick wegen überhitzung abgeraucht. Deswegen auch kein Interesse an das Hat sondern an das externe Teil.


ja, habe ich. Schon so ca 7-8 bei mir und bekannten verbaut
was hat dvb-t stick mit ordentlich verbautem AIS empfänger ist mir nicht ganz klar
beide dAISy varianten ( sowohl HAT als USB) sind absolut empfehlenswert /bin kein Händler/

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

10

Donnerstag, 26. März 2020, 14:11

Hallo, ich hab es wieder versucht.
Jetzt passiert nichts, wenn ich auf - Esc - drücke.
So hab ich es, wie angegeben gemacht:

1.cd ~
wget https://github.com/itemir/rpi_boat_utils…ol/uart_control
chmod 755 ./uart_control
sudo ./uart_control gpio
sudo reboot now

2. gpio readall

3. sudo apt-get install screen

bis dahin geht alles.

Bei 4. screen /dev/serial0 38400 + Esc

ist dann Schluss. Keine Reaktion.

Ich weiß wirklich nicht mehr weiter.
Wer kann helfen?

Jürgen
Wasser ist nass 8o

11

Donnerstag, 26. März 2020, 14:24

Was für RaspberryPi version hast du?

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

12

Donnerstag, 26. März 2020, 14:29

3B

Gesendet von meinem SM-N960F mit Tapatalk
Wasser ist nass 8o

13

Donnerstag, 26. März 2020, 14:48

kannst du mal paar kommandos absetzen und die Ausgabe hier posten?

Quellcode

1
2
3
4
sudo ./uart_control status
ls -la  /dev/serial0
dmesg | grep tty
id $(whoami)

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

14

Donnerstag, 26. März 2020, 15:00

ok, versuch ich mal.
Wasser ist nass 8o

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

15

Donnerstag, 26. März 2020, 15:22

Hier mal das Ergebnis


nach 1.

Console : disabled
UART : enabled
Bluetooth : disabled

UART is available to GPIO 14 & 15.

nach 2.
lrwxrwxrwx 1 root root 7 Mär 26 14:12 /dev/serial0 -> ttyAMA0

nach 3.
[ 0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 bcm2708_fb.fbwidth=1184 bcm2708_fb.fbheight=624 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[ 0.000906] console [tty1] enabled
[ 1.001724] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 81, base_baud = 0) is a PL011 rev2

nach 4.

uid=1000(pi) gid=1000(pi) Gruppen=1000(pi),4(adm),5(tty),20(dialout),24(cdrom),27(sudo),29(audio),44(video),46(plugdev),60(games),100(users),101(input),108(netdev),999(spi),998(i2c),997(gpio)
Wasser ist nass 8o

16

Donnerstag, 26. März 2020, 15:36

sieht perfekt aus.
Es fehlt nur

Quellcode

1
2
3
4
screen /dev/serial0 38400
ESC
ESC
Ctrl+a+k


Wird das evtl von anderen screen session blockiert?

Quellcode

1
screen -ls

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

17

Donnerstag, 26. März 2020, 15:49

nach ESC kommt nichts
Wasser ist nass 8o

pepeldiver

Proviantmeister

  • »pepeldiver« ist der Autor dieses Themas

Beiträge: 261

Wohnort: M/V

Schiffsname: OKIA

Bootstyp: Coronado 25 in Arbeit

Heimathafen: Bei Rerik, 54°2,048`N ; 11°34,370`È

  • Nachricht senden

18

Donnerstag, 26. März 2020, 18:30

Hat blinkt ab und zu.
Sollte ich evtl. die Antenne anschließen?
Wasser ist nass 8o

Andreas29

Salzbuckel

Beiträge: 2 370

Wohnort: OWL-zu weit weg vom Wasser

Schiffsname: Farewell

Bootstyp: Friendship 28

Rufzeichen: Gibt´s nur auf Anfrage

MMSI: die auch

  • Nachricht senden

19

Donnerstag, 26. März 2020, 18:31

Hi,

openplotter ist nicht unbedingt ein vollwertiges Raspian. Manchmal fehlen Bausteine. Deswegen bin ich kein Freund von openplotter, ich nutze lieber Raspbian.

Frage 1: Hast Du screen überhaupt installiert?
Macht man mit Sudo apt-get install screen und würde ich einfach mal durchlaufen lassen. Wenn er sagt ist schon installiert ok, wenn nicht wird's halt installiert.

Frage 2: Hast Du überhaupt irgendwelche Antennen an´s hat angeschlossen und kannst Du AIS-Daten empfangen? Mitten im Binnenland ohne Antenne empfängt das HAT nix und dann gibt dir screen und Co natürlich auch keinerlei Ausgabe

Frage 3: Beim Hochfahren des pi´s leuchten da irgendwelche von den LEDs des HATs?

Frage 4: Als Du das hier: wget https://github.com/itemir/rpi_boat_utils…ol/uart_control ausgeführt hast, was passierte? Du hattest auch ´ne I-net-Verbindung?

Grüße

Andreas
Jahrzehntelang haben sie die Kriegsgeneration gefragt, wie das alles passieren konnte.
Jetzt glauben sie jeden Mist aus dem Internet, schimpfen auf die Lügenpresse, verachten das Politikerpack, pöbeln gegen Flüchtlinge,
verunglimpfen den Rechtsstaat und wählen eine "Alternative für Deutschland".
So passiert das!

20

Donnerstag, 26. März 2020, 18:34

sollte aber, wenn alles gut ist
https://www.youtube.com/watch?v=RH7WOP31A1w

Dann überprüfe mal, ob alles bei dir richtig angeschlossen ist, die kontakte auf RPi nicht verbogen sind, blinkt grünes LED jede 5 sekunden?

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 88   Hits gestern: 3 354   Hits Tagesrekord: 12 076   Hits gesamt: 5 372 281   Hits pro Tag: 2 382,64 
 Seitenaufrufe:   Klicks heute: 827   Klicks gestern: 26 684   Klicks Tagesrekord: 154 353   Klicks gesamt: 41 679 171   Klicks pro Tag: 18 484,99 

Kontrollzentrum