Diese Webseite verwendet Cookies. Durch die Nutzung der Webseite stimmst Du der Verwendung von Cookies zu. Datenschutzinformationen [x]

Sie sind nicht angemeldet.

Werbung

Boote kaufen

Windstärken

Windstärkentabelle

kutt

Matrose

  • »kutt« ist der Autor dieses Themas

Beiträge: 58

Schiffsname: Selene

Bootstyp: Dufour 4800

Rufzeichen: DATE

  • Nachricht senden

1

Sonntag, 24. März 2019, 15:56

oeSENC UserKey nicht korrekt

Hallo,

ich habe zwar schon den Support von o-charts angeschrieben, wollte aber gern mal fragen, ob ich einen Fehler (von mir behebbaren) gemacht habe.

Ich habe auf meinem Navi-RPI den oesenc-pi Plugin installiert und einen Fingerprint generiert. Mit diesem habe ich auf o-charts.org einen Kartensatz generiert (also Karte gekauft, Systemname festgelegt, den Fingerprint übergeben und dann den Kartensatz dafür erzeugen lassen).

Die Dateien habe ich dann auf den RPI kopiert und das Verzeichnis in die Kartenliste eingefügt.

Er fängt an die Karten zu lesen und sagt mir dann, daß der UserKey (der identisch mit dem auf der o-charts Seite ist) nicht korrekt wäre. Auf dem RPI habe ich zwischenzeitlich keine Updates oder andere Änderungen durchgeführt.

Hat jemand schon mal ein ähnliches Problem gehabt?

Das einzige, was ich mir vorstellen könnte ist: Auf der o-charts Seite steht man solle den opencpn-plugin-oesenc installieren. Den gibt es aber nicht. Nach einigem Suchen habe ich gefunden, daß der plugin anscheinend in oesenc-pi umbenannt wurde.

PS: opencpn Version ist die letzte, die man über das Reposity laden kann 4.8.8. (wenn ich mich recht entsinne). Auf dem RPI laufen die letzten (Jessy) Updates.

columbus488

Schief-made

Beiträge: 14 346

Schiffsname: Azurit

Bootstyp: Spirit 28 ( van Heygen )

Heimathafen: Kühlungsborn

Rufzeichen: DD7917

MMSI: 211 625 930

  • Nachricht senden

2

Montag, 25. März 2019, 07:00

sprich mal @bcn: ;)
"Das Meer ist der letzte freie Ort auf der Welt." - Ernest Hemingway

Andreas29

Salzbuckel

Beiträge: 2 288

Wohnort: OWL-zu weit weg vom Wasser

Schiffsname: Farewell

Bootstyp: Friendship 28

Rufzeichen: Gibt´s nur auf Anfrage

MMSI: die auch

  • Nachricht senden

3

Montag, 25. März 2019, 08:10

Hi,

in den letzten Tagen ist OC auf die Version 5.0 aktualisiert worden. Da gab es im Zusammenhang mit dem oesenc-Plugin ein paar Probleme.
Update Dein System nochmal komplett und versuche es dann.

Grüße

Andreas
Jahrzehntelang haben sie die Kriegsgeneration gefragt, wie das alles passieren konnte.
Jetzt glauben sie jeden Mist aus dem Internet, schimpfen auf die Lügenpresse, verachten das Politikerpack, pöbeln gegen Flüchtlinge,
verunglimpfen den Rechtsstaat und wählen eine "Alternative für Deutschland".
So passiert das!

kutt

Matrose

  • »kutt« ist der Autor dieses Themas

Beiträge: 58

Schiffsname: Selene

Bootstyp: Dufour 4800

Rufzeichen: DATE

  • Nachricht senden

4

Montag, 25. März 2019, 09:45

Hallo,

ich glaube ich habe das Problem gefunden. Wobei ich nicht weiß, ob es wirklich etwas miteinander zu tun hat.

Beim generieren der S63 Karten (die nutze ich auch), bekam ich einen Fehler, daß die /usr/bin/OCPNSec nicht ausführbar wäre. Wenn ich die Datei im Shell gestartet habe kam (in etwa):

libstdc++.so.6 version glibcxx_3.4.21' not found
(+ eine weitere)

Obwohl ich denke, daß das nur zum decodieren meiner S63 Karten nötig ist (füge ich keine S63 Karten in der Liste hinzu, dann kommt diese Fehlermeldung auch nicht), habe ich dann ewig nach einem Fix gesucht. Die einzige Lösung, die mir sinvoll erschien, war die libstdc++ zu updaten. bei mir war glaub ich die libstdc++.6.0.20 drauf. Das geht aber nur mit einem dist-upgrade.

Also habe ich in der Hoffnung die Bugs, die OpenCPN mit Debian Stretch anfangs hatte, nun gefixt sein auf Debian 9 aktualisiert.

Und siehe da: Es geht!!!

Evtl. wäre das ein Tip für die Entwickler des Plugins: Anscheined wird keine dependency-check gemacht, also wäre gut, wenn wenigstens die nötige Linuxversion irgendwo stehen würde. Sonst such man sich jedes mal einen Wolf ;)

Ich hoffe das Hilft, falls jemand über ein ähnliches Problem stoplert

bcn

Bootsmann

Beiträge: 120

Bootstyp: Rangeboat 39

Heimathafen: Port Ginesta

  • Nachricht senden

5

Montag, 25. März 2019, 20:11

Kutt,

in solchen Fällen kann man in GitHub den Fehler melden oder im CruisersForum den Finger heben.
Oder eben selber Lösungen einbringen. Ist OpenSource und Beiträge sind hoch willkommen.

Bei den RasPis und oeSENC geht es heute ein wenig rund, aber man ist ja experimentierfreudig. Oder etwa nicht? :P

Hubert

6

Montag, 25. März 2019, 21:43

Bei den RasPis und oeSENC geht es heute ein wenig rund, aber man ist ja experimentierfreudig. Oder etwa nicht? :P

Spass bei OpenSource hört nur auf, wenn dafür Geld verlangt wird... oder? :P

kutt

Matrose

  • »kutt« ist der Autor dieses Themas

Beiträge: 58

Schiffsname: Selene

Bootstyp: Dufour 4800

Rufzeichen: DATE

  • Nachricht senden

7

Dienstag, 26. März 2019, 10:26

Kutt,

in solchen Fällen kann man in GitHub den Fehler melden oder im CruisersForum den Finger heben.
Oder eben selber Lösungen einbringen. Ist OpenSource und Beiträge sind hoch willkommen.

Bei den RasPis und oeSENC geht es heute ein wenig rund, aber man ist ja experimentierfreudig. Oder etwa nicht? :P

Hubert


Moin Hubert, ja stimmt.

Die Sache ist: Um wirklich sicher zu sein, ob meine Vermutung richtig ist, müsste ich ein komplett neues Jessy aufsetzen. Das Debian stammt noch aus wheezy Uhrzeiten und wurde Stück für Stück aktualisiert. Da sich der Rechner den Sommer über auf dem Schiff befindet, entsteht dann immer ein größerer Update-Stau. Der ist so groß, daß normalerweise nach dem "apt upgrade" erst mal gar nichts mehr geht und nur Dependency-Fehler kommen. Ich beschäftige mich aber mit Linux schon echt lange und bekomme das meiste auch so gelöst. In Foren etc. frage ich normalerweise erst, wenn ich mit meinen Latein am Ende bin ;)

Aber gleich mal ein paar kleine Fehler auf der o-charts Seite.
https://opencpn.org/OpenCPN/plugins/oesenc.html
Linux No download needed, install package opencpn-plugin-oesenc <-- das müsste oesenc-pi heißen
Bei einem Click auf "Souce" steht zwar: oesenc_pi, aber in der doc wird von "s63_pi_build" geschrieben. Ich wusste gar nicht, daß die beiden Formate den identischen Algorithmus benutzen?

jensstark

Salzbuckel

Beiträge: 8 401

Wohnort: Halstenbek

Schiffsname: Moi

Bootstyp: Dehler Optima 98GS

Heimathafen: Nestleweg 8, Kappeln

Rufzeichen: DB8094 / (DB9MOI)

Im Marktplatz: 1

  • Nachricht senden

8

Dienstag, 26. März 2019, 14:27

Spass bei OpenSource hört nur auf, wenn dafür Geld verlangt wird... oder?

Das ist für den Einsatz von open source in Firmen oftmals sogar zwingend.

Es geht diesen Kunden darum, in klar definierter Zeit qualifizierten Support zu bekommen - und keine Software einzusetzen, die nach drei Monaten nicht mehr gepflegt wird, weil der Entwickler sich entweder mit dem andern Entwickler zerstritten oder endlich eine Freundin hat.
(Um mal die Vorurteile mal wieder auszulüften... :D )

Es gibt so Standardlösungen, die teilweise *grauenhaft* sind - aber der Firmenkunde hat da diese Sorgen nicht. "Es ist noch nie jemand gefeuert worden, weil er XYZ einsetzt."

Daher gibt es Linuxdistributionen und einiges an Software sowohl open source als auch mit Support.

IngoNRW

Seebär

Beiträge: 1 120

Wohnort: Dortmund

Schiffsname: Naked Lunch

Bootstyp: 50 ft Werftbau mit Hubkiel

  • Nachricht senden

9

Dienstag, 26. März 2019, 15:56

Ich habe exakt das gleiche Problem. Ein neues Tablet gekauft. Apps direkt übertragen, ging einwandfrei, Karten waren aber alle weg. Dann die gekauften neu geladen. Und genau die selbe Fehlermeldung.
Stehe da auch auf dem Schlauch.
:Kaleun_Binocular:
Es ist nicht immer der Wind, wenn die Boote wackeln

10

Dienstag, 26. März 2019, 16:21

Dann die gekauften neu geladen. Und genau die selbe Fehlermeldung.
Stehe da auch auf dem Schlauch.

hast du Fingerprint für das neue Tablet generiert und in o-charts Shop registriert und die Kartensätze dem system zugewiesen?

bcn

Bootsmann

Beiträge: 120

Bootstyp: Rangeboat 39

Heimathafen: Port Ginesta

  • Nachricht senden

11

Dienstag, 26. März 2019, 17:23

Ingo,

Karten ind immer genau für ein System. Man kann den Kartensatz nicht einfach so auf ein zweites kopieren.
Für ein zweites System kannst Du Deine zweite Lizenz verwenden.
Installierst Du wie gehabt auf dem ersten. Aus dem oeSENC Reiter heraus.

Hubert

12

Samstag, 6. April 2019, 23:56

Kann mit hier jemand sagen, warum ich das Paket für das plugin nicht finden kann???
unter KDE läuft es, aber unter Ubuntu Mate für den Pi hakt es noch!
»Heiko« hat folgende Datei angehängt:
  • opencpnFrage.jpeg (15,43 kB - 12 mal heruntergeladen - zuletzt: 14. Juli 2019, 22:33)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Heiko« (7. April 2019, 01:21)


13

Sonntag, 7. April 2019, 08:55

Wenn nur Offizielle repo benutzt wird, dann "oesenc-pi"
Wenn Dave's repo mit Beta, dann sind da sowohl "opencpn-plugin-oesenc-pi" als "auch "oesenc-pi". Wobei die 2 wieder aktuellste.

14

Sonntag, 7. April 2019, 11:37

Wenn nur Offizielle repo benutzt wird, dann "oesenc-pi"

Vielen Dank!! Damit klappt es:

lagita

Moses

Beiträge: 9

Wohnort: Berlin

Schiffsname: TOVA

Bootstyp: IW31

Heimathafen: Szczecin

Rufzeichen: DF2972

MMSI: 211167300

  • Nachricht senden

15

Mittwoch, 19. Juni 2019, 21:33

oesenc-pi Paket wird nicht gefunden

Wenn nur Offizielle repo benutzt wird, dann "oesenc-pi"
Wenn Dave's repo mit Beta, dann sind da sowohl "opencpn-plugin-oesenc-pi" als "auch "oesenc-pi". Wobei die 2 wieder aktuellste.


ahoi! Ich bin auch grade dabei, den RPI mit OpenCPN Vers. 5 zu bespielen, dabei hakts an derselben Stelle.. Ich bekomme nur die Meldung, dass das Paket nicht gefunden wurde.
Ich vermute stark, dass der Fehler vor dem Rechner sitzt, evtl habt Ihr einen Tip für mich?

ciao Matthias

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 405   Hits gestern: 2 997   Hits Tagesrekord: 12 076   Hits gesamt: 5 039 110   Hits pro Tag: 2 358,07 
 Seitenaufrufe:   Klicks heute: 1 735   Klicks gestern: 18 134   Klicks Tagesrekord: 154 353   Klicks gesamt: 39 432 503   Klicks pro Tag: 18 452,62 

Kontrollzentrum