Diese Webseite verwendet Cookies. Durch die Nutzung der Webseite stimmst Du der Verwendung von Cookies zu. Datenschutzinformationen [x]

Sie sind nicht angemeldet.

Werbung

Boote kaufen

Windstärken

Windstärkentabelle

1

Dienstag, 20. August 2019, 10:16

Mit OpenCPN und Raymarine Wegpunkt abfahren

Hallo Zusammen,

Vor einigen Jahren habe ich einen Raymarine Autopiloten Evolution EV1 mit hydraulischer Pumpe in mein Segelschiff eingebaut. Dieser funktionierte bis heute anstandslos.
Auch habe ich die bereits bestehenden Raymarine Geräte ins System mit eingebunden (Siehe Anhang - seatalk.pdf).

Die Lust auf weiteres ist gekommen und darum habe ich mir gedacht, dass es jetzt eigentlich an der Zeit wäre ein Navigations-Programm an den Autopiloten anzubinden.
Natürlich musste auch die Kommunikation hergestellt werden zwischen seatalkng und dem Navi-Programm.

Ich habe mich entschieden für «YachtDevices YDWG-02». Ich muss sagen eine sehr gute Wahl, die ich getroffen habe.
Plug and Play und das Ding empfängt und sendet die Daten ins seatalkng Netz. Hatte ein kleineres Problem, was aber mit dem Kundendienst einfach gelöst werden konnte (Reaktionszeit des Kundendienstes keine 12 Stunden).

Der Entscheid für das Navi-Programm, weil ich es länger schon kenne und auch immer wieder nutze, viel auf OpenCPN.
Und erst kürzlich konnte ich Karten selbst mit openseamap und mit anderen Kartenanbieter einfach erstellen und einlesen.


Somit wäre ich eigentlich startklar für das abfahren von Routen oder einzelnen Wegpunkten. Dachte ich.

Auf dem See folgte dann die Ernüchterung. Ich startete eine Route und sendete diese an den Autopiloten.
Es fing soweit alles gut an jedoch fuhr der Autopilot nicht direkt den Wegpunkt
an bzw. viel immer wieder vom Kurs ab. Am Schluss bin ich dann schon angekommen,
aber ich musste am Display vom Autopiloten immer wieder bestätigen und es kamen
auch immer wieder kurz Anzeigen von Kurskorrekturen. (Siehe VIDEO DirektLink und Bilder).

Hat jemand evtl. dieselbe Konfiguration wie ich und Erfahrung mit den Einstellungen im OpenCPN. Einzig
die Einstellungen unter Verbindungen «Eingangs Filter – Akzeptierte Sequenzen»
habe ich noch nicht herumprobiert. Kann es evtl daran liegen?

Schon jetzt vielen Dank für die Unterstützung.

Gruss Anthony
»Sentinel997« hat folgende Dateien angehängt:

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Sentinel997« (20. August 2019, 21:44)


Homberger

Admiral

Beiträge: 905

Wohnort: Ratingen

Bootstyp: Bavaria 30 Cruiser

Heimathafen: Buyshaven

Rufzeichen: PE3215

MMSI: 244010500

  • Nachricht senden

2

Dienstag, 20. August 2019, 10:29

Hallo,

ich kann mich erinnern, dass ich mit OpenCPN die gleiche Effekte hatte, als ich versuche über die Routenfunktion eine Fernbedienung für den Autopiloten zu bauen.
Leider habe ich nicht herausgefunden, woran es lag.

Das mit der Bestätigung ist aber Raymarine. Die wollen es so. Automatisch zum nächsten WP geht wohl nicht.

Viele Grüße
Andreas
------------
Seatalk Autopilot Fernbedienung und NMEA2000 WiFi Gateway auf GitHub (Link)

3

Donnerstag, 22. August 2019, 10:21

Hallo Andreas

Vielen Dank für deine Antwort.
Ich könnte sehr gut leben, dass ich jeden Wegpunkt nach erreichen bestätigen muss. :rolleyes:
Aber leider pfeift mir bei jeder Kursänderung ein Signal für die Änderung des Kurses "Wende zu Wegpunkt" ins Ohr.
Das sollte doch ausschaltbar sein. Weil diese Bestätigung macht doch gar keinen Sinn.

Gruss Anthony
»Sentinel997« hat folgende Datei angehängt:

Andreas29

Salzbuckel

Beiträge: 2 370

Wohnort: OWL-zu weit weg vom Wasser

Schiffsname: Farewell

Bootstyp: Friendship 28

Rufzeichen: Gibt´s nur auf Anfrage

MMSI: die auch

  • Nachricht senden

4

Donnerstag, 22. August 2019, 10:34

Hi,

ich habe "nur" einen Pinnenpilot ST2000 von Raym. und ich sende Routeninfos von OpenCPN über einen Konverter an den Pipi.

Da klappt soweit. Ich brauche auf den einzelnen Abschnitten nicht manuell eingreifen, da fährt der Pipi den Kurs zum nächsten WP ab.
Was Raymarine aber macht -und so steht´s auch in der Anleitung zum Pipi- ist bei Erreichen eines WPs einen Alarm zu generieren. Dann muss man am Pipi bestätigen, dass es eine Kursänderung zum nächsten WP gibt und erst dann fährt der Pipi auf den neuen Kurs.
Hintergrund ist wohl, so steht´s im Manual, dass man gezwungen ist zu schauen ob die Kursänderung gefahrlos durchgeführt werden kann. Macht auch Sinn m.M. nach.

Warum Dein AP aber bei jeder Kursänderung im Routenmodus auf dem jeweiligen Abschnitt eine solche Bestätigung will erschließt sich mir auf Anhieb auch nicht.

Was hast Du als Ausgangssequenz zugelassen?

Grüße

(auch) Andreas
Jahrzehntelang haben sie die Kriegsgeneration gefragt, wie das alles passieren konnte.
Jetzt glauben sie jeden Mist aus dem Internet, schimpfen auf die Lügenpresse, verachten das Politikerpack, pöbeln gegen Flüchtlinge,
verunglimpfen den Rechtsstaat und wählen eine "Alternative für Deutschland".
So passiert das!

5

Donnerstag, 22. August 2019, 19:36

Hallo Andreas

Für mich macht das soweit auch Sinn, dass man beim erreichen eines WP und bevor es eine Änderung des aktuellen Kurses gibt, diesen Bestätigung muss.
Es stimmt mich aber schon einmal zuversichtlich, dass es bei Dir soweit funktioniert, ohne das man mehrmals beim anfahren eines WP eine Kursänderung bestätigen muss.

Die Einstellungen unter Verbindungen "Eingangs Filter" wie den "Ausgang Filter" habe ich noch nicht bearbeitet. Da muss ich mich zuerst einmal durch die einzelnen Sequenzen-Filter durcharbeiten.
Hast Du den dort Eintragungen vorgenommen? Kannst Du mir evtl. sogar deine Einstellungen mitteilen.

Vielen Dank

Gruss Anthony

Homberger

Admiral

Beiträge: 905

Wohnort: Ratingen

Bootstyp: Bavaria 30 Cruiser

Heimathafen: Buyshaven

Rufzeichen: PE3215

MMSI: 244010500

  • Nachricht senden

6

Donnerstag, 22. August 2019, 19:53

Filter hatten keinen positiven Effekt. Der AP entscheidet das unabhängig von den Sequenzen.
------------
Seatalk Autopilot Fernbedienung und NMEA2000 WiFi Gateway auf GitHub (Link)

Andreas29

Salzbuckel

Beiträge: 2 370

Wohnort: OWL-zu weit weg vom Wasser

Schiffsname: Farewell

Bootstyp: Friendship 28

Rufzeichen: Gibt´s nur auf Anfrage

MMSI: die auch

  • Nachricht senden

7

Freitag, 23. August 2019, 07:50

@Sentinel997:

Anthony, ich kann Dir gerne mal meine Einstellungen rüberbeamen. Am Woende bin ich auf dem Boot, dann schaue ich genau nach was ich da eingestellt habe. Definitiv sende ich nur RMB zum AP, habe also einen Filter für den Ausgang gesetzt.
Die anderen Einstellungen für den Ausgang muss ich nachsehen.

Aber vielleicht hilft Dir ja auch diese Info aus dem OC-Forum weiter (englisch): Klick

Für mich hört sich Deine Beschreibung so an, als ob der AP jedes mal neu den Routenmodus startet. Entweder passt da etwas nicht in den Einstellungen des AP, oder er übernimmt die Routeninfos nicht (warum auch immer) oder er bekommt sie nicht.

Eine andere Möglichkeit ist, dass Du über Dein Netzwerk zu viele (und ggf. Widersprüchliche) Informationen sendest. Sendet vielleicht Deine GPS-Quelle ebenfalls Routensequenzen in´s Netzwerk?

Was Du in OC gut machen kannst ist ja in dem Einstellungsmenue/Ein-Ausgänge den NMEA Datenverkehr mitzulesen, dafür ist das Debug-Fenster da. Da kannst Du genau sehen welche Ein- und Ausgangssequenzen gesendet werden. Das kann schon mal erste Auskünfte geben.
Wenn dann Dein Rechner mit OC die "richtigen" Ausgangssequenzen sendet kann es ggf. ja noch sein, dass der Konverter parametriert werden muss, damit er dann auch die richtigen Sequenzen weitergibt.

Grüße

Andreas
Jahrzehntelang haben sie die Kriegsgeneration gefragt, wie das alles passieren konnte.
Jetzt glauben sie jeden Mist aus dem Internet, schimpfen auf die Lügenpresse, verachten das Politikerpack, pöbeln gegen Flüchtlinge,
verunglimpfen den Rechtsstaat und wählen eine "Alternative für Deutschland".
So passiert das!

Andreas29

Salzbuckel

Beiträge: 2 370

Wohnort: OWL-zu weit weg vom Wasser

Schiffsname: Farewell

Bootstyp: Friendship 28

Rufzeichen: Gibt´s nur auf Anfrage

MMSI: die auch

  • Nachricht senden

8

Mittwoch, 28. August 2019, 19:09

@Sentinel997:

Hi,

im Anhang die Einstellungen für den Ein/Ausgang. Dieser Eingang bekommt alle NMEA-Sätze die über den gesamten Bus schwirren. Damit es nicht zu Irritationen kommt habe ich bestimmte Sequenzen ausgefiltert. RMB und RMC sollen nicht von anderen Quellen ausser Opencpn an den AP kommen, daher ausgeblendet.
HDM und HDG will ich nur von einem elektronischen Kompass haben, der an einem anderen Eingang hängt, daher an diesem Eingang ausgeblendet (der AP sendet nämlich auch HDM Infos über die Seatalkbridge in´s Netz)

Ausgang: Dort lasse ich nur die RMBsätze raus. Lasse ich auch RMCsätze raus verliert Opencpn komischerweise die Infos über SOG und COG. Warum? K.A. aber nur RMB geht.

1.Versuche für den Anfang eine Markierung in die Karte zu setzen und sage dann mit rechtsklick navigiere dorthin. Dann bekommst Du rechts die Routeninfos und die Autobahn eingeblendet. Damit sollte dein AP die nötigen Infos bekommen und sollte eigentlich im Track-Modus nachdem einmalig die Kursänderung auf WP bestätigt wurde das stumpf abfahren bis da.

Wenn das funzt kannst Du versuchen das Ganze mit einer Route zu machen. Das sollte auch klappen, aber man muss genau darauf achten was wie und welcher Punkt aktiviert wurde.

Wenn 1. nicht klappt ist hoffentlich noch eine Einstellung am AP nötig, wenn nicht ist evt. Deine NMEA-Seatalk Schnittstelle noch anpassungsbedürftig und hoffentlich -fähig.

Grüße

Andreas
»Andreas29« hat folgende Dateien angehängt:
  • 1.jpg (156,74 kB - 12 mal heruntergeladen - zuletzt: 3. November 2019, 07:42)
  • 2.jpg (138,12 kB - 11 mal heruntergeladen - zuletzt: 3. November 2019, 07:42)
  • 3.jpg (130,93 kB - 11 mal heruntergeladen - zuletzt: 3. November 2019, 07:42)
Jahrzehntelang haben sie die Kriegsgeneration gefragt, wie das alles passieren konnte.
Jetzt glauben sie jeden Mist aus dem Internet, schimpfen auf die Lügenpresse, verachten das Politikerpack, pöbeln gegen Flüchtlinge,
verunglimpfen den Rechtsstaat und wählen eine "Alternative für Deutschland".
So passiert das!

Counter:

Gezählt seit: 4. Februar 2014, 08:39, nur eingeloggte Mitglieder
 Zugriffe:   Hits heute: 2 462   Hits gestern: 3 489   Hits Tagesrekord: 12 076   Hits gesamt: 5 371 301   Hits pro Tag: 2 382,58 
 Seitenaufrufe:   Klicks heute: 19 786   Klicks gestern: 26 680   Klicks Tagesrekord: 154 353   Klicks gesamt: 41 671 446   Klicks pro Tag: 18 484,47 

Kontrollzentrum