Raspberry Schnitstellen Openplotter / signalk >>MarineControlServer

  • Von aussen erreichst AvNav mit http://<hostname|ip>:8080


    Enweder du stellst die Widgets im AvNav auf SignalK Werte oder im signalk-nmea0183 lässt du die NMEA0183 Winddaten exportieren

    Vielen Dank für deine Antworten BlackSea, für mich habe ich inzwischen herausgefunden, wie ich die Wlan-Einstellungen in openplotter machen muss, damit ich vom Smartphone oder Tablet direkt auf AVNAV komme. Das ist soweit gelöst.


    Was ich immer noch nicht hin bekomme, ist die Verbindung zwischen dem Nasa-Windmesser und AVNAV. Wo muss ich da was einstellen, damit es vom Eingang am MCS bis zu AVNAV durchläuft?

    Michael

  • als erstes überprüfe ob Winddaten überhaupt ankommen

    Öffne in SignalK "Data Browser" und finde ob die Daten da korrekt sind. Wenn nein, dann liegt Hardware problem vor

    Wenn Ja

    1. Öffne in SignalK Server->Plugin Config -> Convert SignalK to NMEA0183 und anhacke MWD und MWV Sätze

    Nach dem restart von SignalK kannst du wieder überprüfen ob die von SignalK wirklich geliefert werden

    Auf kommandozeile

    Code
    nc localhost 10110

    Sollen die entsprechende Sätze auftauchen

    Dann gehst du in AvNav und überprüfst die Werte in Widget

    Wenn Widget dir nicht gefällt kannst du ein anderen benutzen ( z.B. WindGraphics )

    Wellenvogel-AvNav

    🇺🇦

  • Über welche AvNav Version auf Openplotter reden wir?

    In den neueren Versionen ist es nicht mehr nötig, die Daten in SignalK erst in NMEA0183 zu übersetzen, um sie zu AvNav zu schicken.

    Im SignalK Handler in AvNav ist dazu "decodeData" eingeschaltet (wenn noch nicht, dann kann man das nachholen).

    Siehe https://www.wellenvogel.net/so…ndSignalk.html#h2:SignalK.

    Dort findet man auch die Info, welche Werte aus SignalK direkt in AvNav dekodiert werden.

    Aber erst mal müssen sie in SignalK vorhanden sein...

  • Das hat dann mit AvNav nichts mehr zu tun.

    Du musst jetzt erst mal schauen, warum Deine Winddaten nicht in SignalK ankommen.

    BlackSea hat ja schon geschrieben, wo Du nachschauen solltest.

    Welche Einstellungen hast Du in SignalK für den seriellen Anschluss vom Windmesser?

  • Happy New Year to all.

    A question for glowntiger (edited by mod): Do you foresee an integration with the new Bookworm system — the new version of the Raspberry Pi operating system?


    Frohes neues Jahr an alle.

    Eine Frage an glowntiger (edited by mod): Sehen Sie eine Integration mit dem neuen Bookworm-System – der neuen Version des Raspberry Pi-Betriebssystems?


    @ Max1947 Edit: Linked user refuses to publish real name.

  • Hallo,


    Die Stromversorgung, 5V, habe ich direkt auf den 1-Wire-Anschluss vom MCS gelegt. Funktioniert.

    Die Stromversorgung hat nichts am 1-wire zu suchen. Das ist ein Ausgang der rein für 1-wire Sensoren gedacht ist. Versorgung rein über den 12v Eingang.

  • Happy New Year to all.

    Do you foresee an integration with the new Bookworm system — the new version of the Raspberry Pi operating system?

    Hi Max,

    please delete my name in your comment. You can use glowntiger :winking_face:

    To your question; The hardware doesn't care which operating system you use :smiling_face: Not sure if signalK, AVNav and so on already runs with it. I haven´t tested it. Will test it in my boat soon when i update my system. But i think it will work.

    Thomas

  • Not sure if signalK, AVNav and so on already runs with it.

    Most probably our next image will be based on bookworm.

    But no timeline yet.

    For avnav itself there should be no issue. For the o-charts plugin there is a beta for bookworm.

    But as always: Until someone is testing this carefully we cannot be sure. Not unlikely to see some surprises.

  • Die Stromversorgung hat nichts am 1-wire zu suchen. Das ist ein Ausgang der rein für 1-wire Sensoren gedacht ist. Versorgung rein über den 12v Eingang.

    Hallo glowntiger, ist das Zitat aus dem Zusammenhang mit der 5V-Spannungsversorgung für das 5V LCD-Display gerissen oder muss ich tatsächlich einen separaten Spannungswandler an den 12V-Eingang setzen?

  • Ich hatte es so verstanden, dass Du das MCS mit 5V über den 1-wire Anschluss versorgst? Das solltest Du nicht tun aber ich glaube Du meinst, das Du das Display vom MCS versorgst, also die Spannung abgreifst richtig? Liegt dann an der Stromaufnahme vom Display... wenns läuft... :winking_face:

  • Hello guys

    Im new to this boat life, I live in my sailboat and it has a MCS V1.5, but not installed

    Im trying to put my AIS in it via NMEA0183 to further get it in my navionics app via wifi.

    I do have a AIS MCMurdo Smartfind M10 connected to the MCS, and the MCS connected to the PI4.

    Ive done all the necessary configs in all the tutorials I found, but I cannot see any data in Data Browser in SignalK.

    Do you guys have a step by step so I can study it or someone can help me do this first step?

    Thank you in advance

  • Would be good to know about the hardware connection first, i.e. how did you connect your AIS.

    Second: What software distribution do you run on the Pi?

    The serial interfaces of the MCS need to have the correct overlays enabled.

    How to do this depends on the distribution.

  • Moin allerseits und wohl vor allem glowntiger


    habe heute mal zum Spaß die Openplotter 4 Beta installiert.

    Das MCS-Plugin für SignalK läuft darauf nicht. Einmal liegt das wohl daran, dass die eigentliche config.txt nun in einem Unterordner liegt (/firmware). Das MCS-Plugin meldet zwar, dass alles i.O. sei, aber die seriellen Schnittstellen des MCS werden im Plugin nicht erzeugt.

    Das Kopieren der MCS-Einträge in /firmware/config.txt führt zum Teilabsturz der Oberfläche.


    Gibt es schon Pläne zum Update des MCS-PlugIn?


    Ansonsten läuft das schon fein schnell und flüssig und AvNav auch…;-)


    Gruß Michael

  • glowntiger :


    Wäre auch interessiert zu wissen Was mit dem MCS Plugin geschieht. Um den Raymarine EV Autopiloten mit Opencpn zu benutzen benötigt man die letzte Version von Opencpn


    Das Problem bisher war den Autopiloten über NMEA2000 zu steuern. Gerade im im Cruiser Forum folgendes gelesen:


    Re: AutoTrackRaymarine_pi: Remote control and route following for Evolution Pilots vom 14.03.2024

    The original (older) version of the AutoTrackRaymarine controlled the NGT-1 directly and only functioned with the NGT-1. Now OpenCPN supports nmea2000, we use OpenCPN to transmit and receive nmea2000 messages. So the AutoTrackRaymarine plugin will function with all nmea2000 interfaces on any platform that OpenCPN supports. So we are no longer dependent on the NGT-1 only.

  • Für das neue 64 bit System auf dem Raspberry arbeitet der MCS Plugin noch nicht. Um die neue Version von Opencpn zu betreiben brauche ich den Plugin.

    BlackSea besitzt du das MSC und benutzt Openplotter oder Opencpn?

    Das Problem ist mit dem EV Autopiloten, der nicht sauber funktioniert mit NMEA2000....also im Prinzip gar nicht.

    Schaue mal weiter oben bei Moeritsen .....Was nützt das MCS wenn die Interfaces nicht mit dem neuen OS funktionieren. Signalk braucht den MCS Plugin.

  • SignalK braucht "can" schnittstelle. Plugin übernimmt nur ersteinrichtung. Danach ist Plugin völlig überflüssig


    Ich verstehe nicht ganz wieso braucht man unbedingt "neuste" OP4 ( was eigentlich noch BETA ist) wenn das mit OP3 sofort funktionieren würde. Aber egal

    Nicht desto trotz.

    1. Entweder man wartet auf glowntiger

    2. Oder "Rettung von Sinkenden ist die Sache von Sinkenden"

    Ich nehme an, du hast schon Plugin installiert und Plugin hat paar Zeilen in /boot/config.txt hinzugefügt. Du kannst prüfen mit

    Code
    tail /boot/config.txt

    Soltte da sowas stehen

    Code
    dtoverlay=sc16is752-i2c,int_pin=13,addr=0x4c,xtal=14745600
    dtoverlay=sc16is752-i2c,int_pin=12,addr=0x49,xtal=14745600
    dtoverlay=sc16is752-i2c,int_pin=6,addr=0x48,xtal=14745600
    dtoverlay=mcp2515-can1,oscillator=16000000,interrupt=25

    Du trägst dann diese magische Zeilen in /boot/firmware/config.txt ein

    Und rebootest


    Viel Spass


    besitzt du das MSC und benutzt Openplotter oder Opencpn?


    Habe ich auch stehen. Aber nicht in "Produktion"

    🇺🇦

  • Danke für die Tipps . Hatte eigentlich das MSC Bord schon aufgegeben und mir ein Waveshare 2 X485 plus Can Bus besorgt.

    Für mich ist wichtig, dass der Autopilot funktioniert und die Karten. Opencpn hat mehrere Jahre gebraucht um den Raymarine EV ans arbeiten zu bekommen ohne zusätzlichen NGT-1....bin mal gespannt ob es funktioniert....sonst kaufe ich mir einen AXION Plotter....langsam geht es so wie mit Pypilot...zum Schluss habe ich mir den Raymarine EV200 mit Linear Antrieb gekauft

    Wusste nicht, dass die Plugins nur für die Konfiguration gebraucht werden. Die Selbstbau Lösungen auszuprobieren macht im Winter Spaß, aber im Sommer da ich oft alleine segele muss alles funktionieren. Den Raspi habe ich noch nicht ins Boot eingebaut, habe alles zum Navigieren.

    Während meines Berufsleben erst Data General Assembler mit Rdos, danach Digital VMS UNIX, dann Windows und Sun Solaris in den letzten 10 Jahren meines Berufslebens....habe mit IT 1975 begonnen....